Skip to:

Reply link doesn't seem to work

  • Hello,

    I have just installed bbPress at this URL and the installation all seemed to complete without a problem.

    However, I have created a couple of test topics, but I seem to be unable to reply to any posts. I can create a new post, but if I click on the link that says ‘Reply >>’ beneath a post, nothing happens. ‘#postform’ gets added to the URL in the address bar, but there is no area for me to enter a reply.

    Can anyone help me? I haven’t integrated bbPress with my WordPress installation (I don’t think I want to for this site), and I have activated Askimet.

    If anyone can give me some advice I’d be really grateful!

    Many thanks,


Viewing 7 replies - 1 through 7 (of 7 total)
  • What plugins are you using?

    Did you edit the php in anyway?

    It should be:


    You must log in to post.” and the “Reply” is not a link. The reason is because the user has to be logged in first to reply.

    Thanks for the quick reply!

    The only plugin currently activated is Askimet. I tried deactivating it just now, but it didn’t make any difference.

    I haven’t touched the PHP at all – I might do when I come to customise it, but I’m hoping that will only be the template files and none of the workings. I’ve literally only got as far as installing it and spending about half an hour clicking around in it.

    I’ve tried it in Chrome and in IE8 but it was the same in both.

    It does say ‘Reply. You must log in to post.’ when I’m not logged in, but the second sentence goes away when I’m logged in. The Reply is a hyperlink, but only to the #postform anchor, and there doesn’t seem to be any post form on the page.



    Wow. That’s kinda strange. Your site does show the replay link that is used on thread pages that aren’t actual the last page. Go to:

    and tell me whay you got.

    I’ve just got “Items per page – 30”, and then Save Changes.

    I hope I haven’t done something really weird to it. I don’t think I did!

    Waaaaaaaaaaaaaaaaaait a minute, I think I’ve fixed it.

    Thanks for your efforts guys! Having written “the installation all completed correctly”, it reminded me that one of the files got skipped for no apparently reason when I FTP-ed them onto the server. I uploaded that one separately straight away, and then everything seemed fine when I installed, but in actual fact it seems that the last 30 or so lines of bb-settings.php were missing.

    You mentioning the PHP and the settings made me think to go in and look.

    I’ve re-uploaded the file, and now the reply box is appearing under the posts, and the Reply text is no longer a link.

    Sorry, I haven’t a clue why that happened, but you guys helped me track it down and I’m grateful.



    Can you tell us what file you missed? I have a similar issue but I don’t even know what file to look for.


    My problem was caused by the file bb-settings.php (in the root folder of the forum) only being partially FTP-ed to the server. About 20 lines were missing from the end of it. I mentioned that it was that file in my previous post.

    It seems unlikely to me that you’d have exactly the same problem as it seems to have been an FTP issue to do with my computer or web host. You could check your bb-settings.php file though just to be sure. It should be 1219 lines long and the last line should read


Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.
Skip to toolbar