Skip to:
Content
Pages
Categories
Search
Top
Bottom

Redirect Loop after installation

  • Hello everybody,

    I tried to install bbpress on my webspace, but ran into a few problems and seem to struggle getting it running.

    First of all: I’m using the alpha 1.0, because i want to integrate it into WP 2.61 installation. The directories are structured like this:

    root

    root/blog (my WP installation)

    root/blog/bbpress (desired bbpress installation)

    I have downloaded the files yesterday, have modified my bb-config.php (double checked the keys, so they match my WP-keys, even tried out with keys that contain no special characters). After uploading i went through the installation process (where i had to reenter the keys) and filled the two cookie salts, which I found in my WP-Installation.

    Everything went well, up to the point, where the log is printed out, which states: “Forum cannot be created.” (Any other .log entries point out no problem)

    If I now try to load the page, I get a redirecting loop (hope it’s a good translation).

    I even tried to clear all database tables, and installed again, but the same problem occurs.

    I hope that someone maybe has a hint, what I am doing wrong.

    Thanks

    Felix

Viewing 14 replies - 1 through 14 (of 14 total)

  • chrishajer
    Participant

    @chrishajer

    Please post your URL.

    the url of the forum:

    http://www.fl3x.org/blog/bbpress/

    the url of the blog:

    http://www.fl3x.org/blog/

    p.s.: you might get a warning when entering the page. the site was hacked and i had to set up the page completely new yesterday. A new review by google is queried, but not yet done.

    So, the warning might still be shown.


    chrishajer
    Participant

    @chrishajer

    **edit**

    I am using the latest WordPressMU with the Alpha release of bbPress.

    **end-edit**

    I am actually receiving this same error. I tried installing initially and completed the install until the final step where I needed to create a forum. I tried to make a Hello World forum and I got an error saying that the installation failed. I couldn’t go back a step or anything .

    I just gave up on that install since it was fairly quick anyways, and removed the bbpress directory. I then re-downloaded the install file, unzipped it into my root directory and re-attempted the install. Now, whenever I try and re-install by going to the url that contains the bbpress install http://danvollans.com/bbpress I get a redirection error after the first step where I input my database information. I have since not been able to get past this step. Any help on this would be greatly appreciated, especially since now I believe I’m not the first to receive this type of error.

    Thank you very much!


    chrishajer
    Participant

    @chrishajer

    What is the exact message shown when the installation fails? Does anyone have the exact wording? I’m trying to look through the installation to see where the failure occurs.

    I know if will be hard to go back and get the message now since you are stuck in a loop.

    If deleting the directory doesn’t work, the installer must be checking for the presence of *something* in the database, right?

    Yeah, I have been looking for something similar. My error occurred actually in a different spot now that I remember. The issue that I was running into was when I created the KeyMaster user, I named it admin, foolishly. This came with an error saying that the user is already in my wordpress database so it could not create user “admin”. That is where the loop began. I have since cleared my cache, search history, and everything that you can clear in firefox including cookies.

    I also tried this in Safari so it is most definitely not a browser related issue, or an issue with the actual bbPress, since this isn’t very common. It then must be a database issue, so I’ll continue to look into it.

    Thanks for the ideas. :D

    The actual error I receive that brings me to this loop is:

    The key master could not be created. You may need to replace bbPress with a fresh copy and start again.

    The error log shows:

    >>> Key master could not be created!

    >>>>>> Halting installation!

    After this, anything or anywhere I go, UNTIL I completely delete the bbpress database and the bbpress directory. Then I can re-install, but I get the same error with the same loop.

    Even deeper, this is a problem with the wordpress integration for me. I tried installing without integrating and it worked just fine. It’s possible that for me the integration must come afterwards.. =/

    in my case I can successfully go through step 2, and the system tells me:

    “Your WordPress integration cookie and database settings have been successfully validated. They will be saved after the next step.

    …”

    After that I name the forum, choose my normal WP-Admin-User,etc.

    When I want to complete the next step it prompts me with: Installation Errors:

    “Forum could not be created!” and tells in the complete log:

    “Referrer is OK, beginning installation…

    >>> Setting up custom user table constants

    Step 1 – Creating database tables

    >>> Modifying database: <my_db> (<my_host>)

    >>>>>> Table: bb_forums

    >>>>>>>>> Creating table

    >>>>>>>>>>>> Done

    >>>>>> Table: bb_meta

    >>>>>>>>> Creating table

    >>>>>>>>>>>> Done

    >>>>>> Table: bb_posts

    >>>>>>>>> Creating table

    >>>>>>>>>>>> Done

    >>>>>> Table: bb_tagged

    >>>>>>>>> Creating table

    >>>>>>>>>>>> Done

    >>>>>> Table: bb_tags

    >>>>>>>>> Creating table

    >>>>>>>>>>>> Done

    >>>>>> Table: bb_terms

    >>>>>>>>> Creating table

    >>>>>>>>>>>> Done

    >>>>>> Table: bb_term_relationships

    >>>>>>>>> Creating table

    >>>>>>>>>>>> Done

    >>>>>> Table: bb_term_taxonomy

    >>>>>>>>> Creating table

    >>>>>>>>>>>> Done

    >>>>>> Table: bb_topics

    >>>>>>>>> Creating table

    >>>>>>>>>>>> Done

    >>>>>> Table: bb_topicmeta

    >>>>>>>>> Creating table

    >>>>>>>>>>>> Done

    >>>>>> Table: wp_users

    >>>>>>>>> Changing column: ID

    >>>>>>>>>>>> Done

    >>>>>>>>> Changing column: user_login

    >>>>>>>>>>>> Done

    >>>>>>>>> Changing column: user_pass

    >>>>>>>>>>>> Done

    >>>>>>>>> Changing column: user_nicename

    >>>>>>>>>>>> Done

    >>>>>>>>> Changing column: user_email

    >>>>>>>>>>>> Done

    >>>>>>>>> Changing column: user_url

    >>>>>>>>>>>> Done

    >>>>>>>>> Changing column: user_registered

    >>>>>>>>>>>> Done

    >>>>>>>>> Changing column: user_status

    >>>>>>>>>>>> Done

    >>>>>>>>> Changing column: display_name

    >>>>>>>>>>>> Done

    >>>>>> Table: wp_usermeta

    >>>>>>>>> Changing column: umeta_id

    >>>>>>>>>>>> Done

    >>>>>>>>> Changing column: user_id

    >>>>>>>>>>>> Done

    Step 2 – WordPress integration (optional)

    >>> WordPress address (URL): http://www.fl3x.org/blog/

    >>> Blog address (URL): http://www.fl3x.org/blog/

    >>> WordPress cookie keys set.

    >>> WordPress “auth” cookie salt set from input.

    >>> WordPress “logged in” cookie salt set from input.

    >>> Fetching missing WordPress cookie salts.

    >>>>>> WordPress “secure auth” cookie salt not set.

    >>> User database table prefix: wp_

    Step 3 – Site settings

    >>> Site name: fl3x Forum

    >>> Site address (URL): http://www.fl3x.org/blog/bbpress/

    >>> From email address: <my_email>

    >>> Key master role assigned to existing user

    >>>>>> Benutzername: <admin_user>

    >>>>>> E-Mail-Adresse: <my_email>

    >>>>>> Passwort: Your existing password

    >>> Beschreibung: Just another bbPress community

    >>> Forum could not be created!

    >>> Key master email sent

    There were some errors encountered during installation!”

    Thats all, and afterwards I won’t see a forum, I only get error messages on Firefox regarding a redirection loop.

    The reason for the loop is that it’s trying to create repeat tables in the database, either new database or the wordpress database, whichever one you chose to use. I believe this is the cause for the loop, if you go into mysql, use:

    mysql -u <user> -p

    and then type your password

    type:

    use <databasename>

    then type show tables;

    and then type drop table <table name with prefix bb_>

    and drop each table that was a remnant of bbpress. This is the way to start a new install.

    My issue is resolved. There was an issue with the user tables not collaborating, so I put WPMU 2.6 and bbPress 1.0 Alpha in separate databases, and followed _ck_’s tutorial on install. I also used the plugin for loss of admin access. Everything now works beautifully. (so far! :) )

    WordPress:

    http://blog.danvollans.com/wpmu/

    bbPress:

    http://danvollans.com/bbpress/


    amit1234
    Member

    @amit1234

    I am installing bb press and wordpress mu in same database I install it successfully but when I am trying to login in admin panel of wordpress-mu I redirect to page I am not able to control my addmin panel cuold you help in that


    chrishajer
    Participant

    @chrishajer

    amit1234 please start a new topic for your problem. thank you.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.
Skip to toolbar