Skip to:

Private BuddyPress group’s forum not private

  • cjerrells



    I’ve been having difficulties setting up a private BuddyPress group with associated forum:

    1. If the forum is set as “private” then I get the error “This group does not currently have a forum.” on the group’s Forum page.

    2. If the forum is set as “public” then the forum does appear there, and the group’s access controls seem to stop non-members accessing it. However new topics and replies generate BuddyPress activities which are visible to non-members.

    WordPress 4.7.4
    BuddyPress 2.8.2
    bbPress 2.5.12

    I was advised on trac ticket #2752 (here) to try the fix on trac ticket #2599 which updates forum privacy when the group is saved. I tried this, but it just set the forum as private, triggering problem #1.

    As mentioned on the trac ticket linked above, I have tried the Repair tools and various changes to group/forum privacy.

    I can’t seem to find a setup that gives me a private group with a private forum. Can anyone please advise me on how to debug this?

  • You must be logged in to reply to this topic.
Skip to toolbar