Skip to:

“pretty” permalinks in bbPress

  • I just setup v0.9 and the default URL structure works. However if I try to select another permalink option and save settings, it saves the settings but then breaks all external URLs = page not found. All I have right now is 1 category and the 1 sample post. Both break, and become functional again when I revert back to default permalink.

    Any idea how to make this work?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Did you update your htaccess file?

    Angie: I’ve not touched the htaccess file, and I probably need to do it. WordPress usually updates it automatically… what should I put in it? I want to use the name based option …/forum/first-forum.

    OK — I stumbled upon the FAQ and saw the htaccess code to add. I LOVE the URLs, could never get to this in phpBB. If this thing is secure, I’m going to love bbPress. Kudos to the dev team, very cool forum software!

    And thanks Angie!

    bbPress permalinks still not working for me.

    I have also a wordpress installation with the same hosting company on the same account. Rewrite works perfectly.

    My bbPress site 0.9.04:

    I tried ‘MultiViews’ and the ‘generated Rewrite rules’ in my .htacess file and nothing gets the pretty links to work. The html links are generated well but the pages are not found.

    There must be something else. Any hints for me?

    I am not into the Unix stuff too much and I am wondering if .htaccess files need a kind of ‘server restart’ or etc.???

    When I installed bbPress I also needed to add a line that instructs the server to use PHP5 instead of prev. versions. The bbPress requirements spoke always about PHP >4.3… so that was not right as well. I am wondering if the permalink stuff is may be not 100% at this point.

    Besides of that… bbPress is definitely a super cool product from you WP guys! It rocks and finally brings a good looking message board on the plate. Good work. Thanks!

    I appreciate a help re. the permalinks.




    There is no restart required for modifying an .htaccess file: Apache reads that for every access.

    The permalinks are not related to PHP4 vs PHP5.

    The permalink stuff is definitely 100% right now, at least for the 0.9.x series.

    I’m assuming you made the change in the admin to turn on the permalinks, in conjunction with adding the .htaccess rewrite rules?

    I had to insert this into my .htaccess to turn OFF the multiviews before the rewrite rules would work:

    Options -MultiViews

    Hi chrishajer,


    I added the additional Options line and it works now.





    As an aside, some hosts such as GoDaddy can take around 30 minutes for the .htaccess file to be read and implemented.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.
Skip to toolbar