Skip to:
Content
Pages
Categories
Search
Top
Bottom

Postings not showing up?


  • Micheal
    Participant

    @micheal0424

    I create a forum and it is seen on my forums page, no problem there.

    When a forum is selected the list of topics for that forum appear with no problem.

    When a topic is selected the Posts that were previously entered are not showing up?

    What do I need to do to get them to show up?

    As an admin I can see my own and I can see the participant posts, but the participant can’t see my posts or their own posts. They are able to see my reply to their post but still not their posts?

    I have turned all plugins off and it still doesn’t work. I doubt it is a theme problem because the theme is use is also the them the website I got it from uses and they use the forum with no problem.

    What could the problem be?

    Thanks for your help, it is greatly appreciated (frustrating day)!!

Viewing 25 replies - 1 through 25 (of 28 total)

  • Stephen Edgar
    Keymaster

    @netweb

    Try testing with the Twenty Fourteen theme, to confirm if it is a theme issue or not.


    Micheal
    Participant

    @micheal0424

    I tried the Twenty Fourteen theme and I am still having the issue.

    Any other ideas?

    I have tried everything I can think of.

    Thanks for the help.


    Micheal
    Participant

    @micheal0424

    I forgot to mention that I tried different browsers as well and have the same problem.

    When a participant creates a post they can’t see there own post or that they even posted except under the topic section they can see they started it. I would give you the link to see all of this but it is in our members area.

    I can send you a PM if possible with information you will need to see the issues if that helps?

    Thank you.


    Stephen Edgar
    Keymaster

    @netweb

    A couple of screenshots should suffice, post a couple of screenshots and we’ll go from there.


    Micheal
    Participant

    @micheal0424

    bbPress1

    The first image shows the forums.

    bbPress2

    This image shows the topic “Payout” previously entered by the participant.

    bbPress3

    This image shows the response but not the original entry.

    These images screen shots taken from the participant being logged in.

    When the participant tries to look at any other topic they don’t see what has been posted, they only see the one that Micheal replied to (just not there post that was being replied to).

    —–

    Here is what Micheal sees when he is logged in:

    bbPress4

    As you can see in this image Micheal can see the original post and his own.

    —–

    When Micheal is logged in he can see his own posts but when the participant tries to look at the same post they don’t see anything Micheal has posted (except his response to their post).

    Any Ideas?

    Thanks.


    Micheal
    Participant

    @micheal0424

    To sweeten the pot, if you can help me resolve this I will name my next born after you!!


    Stephen Edgar
    Keymaster

    @netweb

    Is either the topic or reply status ‘private’ or ‘pending’?


    Micheal
    Participant

    @micheal0424

    No


    Micheal
    Participant

    @micheal0424

    Where would I see the pending?

    The setting is on Public.


    Stephen Edgar
    Keymaster

    @netweb

    If you look in the Topics and Replies you would see ‘pending’


    Micheal
    Participant

    @micheal0424

    I see nothing in comments, it is empty.

    I see the reply in the Replies area though.


    Stephen Edgar
    Keymaster

    @netweb

    My, bad, mouse was hovering over ‘Comments’, sorry, that is the ‘Replies’ section.

    So do you see ‘private’ or ‘pending’ in the ‘replies’ or ‘topics’ panels as above?


    Micheal
    Participant

    @micheal0424

    No ,there is no private or pending like on your screen.


    Micheal
    Participant

    @micheal0424

    I am still puzzled where the posts are, I thought there would be an area like the comments or replies for that.


    Stephen Edgar
    Keymaster

    @netweb

    – Do you have ‘Auto Role’ checked and what role is it set to? (Dashboard -> Settings -> bbPress)


    Stephen Edgar
    Keymaster

    @netweb

    I am still puzzled where the posts are, I thought there would be an area like the comments or replies for that.

    This statement here confuses me… You should see Forums, Topics, and Replies sections like I have in my previous screenshot. All the ‘posts’ should show here, you only see the title of the post and not the full content until you open it with the ‘edit’ row action (mouse over a title).

    Are you not seeing your topics or replies in each section?


    Micheal
    Participant

    @micheal0424

    Yes.

    Auto role Automatically give registered visitors the “participant” forum role


    Stephen Edgar
    Keymaster

    @netweb

    Have you run the “Remap existing users to default forum roles” repair tool? If not, do so.

    Any change?

    Edit: And answers to my previous question please 🙂


    Micheal
    Participant

    @micheal0424

    This statement here confuses me… You should see Forums, Topics, and Replies sections like I have in my previous screenshot. All the ‘posts’ should show here, you only see the title of the post and not the full content until you open it with the ‘edit’ row action (mouse over a title).

    Are you not seeing your topics or replies in each section?

    YES, I do.

    bbPress7

    Here is Topics screen shot.


    Micheal
    Participant

    @micheal0424

    Just ran the tool and only selected the “Remap existing users to default forum roles” box and pressed repair items button, still not fixed.


    Stephen Edgar
    Keymaster

    @netweb

    I’ve got nothing else at the moment…

    Let me think on it for a bit…

    I also presume you still have all your plugins except bbPress deactivated?

    Also what theme is it you are using?

    Have you any custom code in a functions.php file running?


    Micheal
    Participant

    @micheal0424

    Are you not seeing your topics or replies in each section?

    Refer to my screen shots before to make sure I am not getting confused to what you are asking here.

    For the one I referenced the participant did this:
    Forum(General Questions)>Topic(Payout)>

    When they go there they see the response to what they entered earlier but they don’t see what they posted earlier.

    What is odd though is when I go to the same page I see her original post and my response to her question. She doesn’t see that though, she just sees my response.

    ———-
    This is what she sees as a Participant:
    bbPress8

    This is what I see as Admin:
    bbPress10


    Micheal
    Participant

    @micheal0424

    I also presume you still have all your plugins except bbPress deactivated? YES, I turn them off when trying everything.

    Also what theme is it you are using? http://themeforest.net/item/enfold-responsive-multipurpose-theme/4519990?ref=Kriesi

    Have you any custom code in a functions.php file running? NO


    Stephen Edgar
    Keymaster

    @netweb

    Ok, that, still with you….

    Can you please post two new screenshots are the same two you just posted for the Forum(General Questions)>Topic(Payout) though using the Twenty Fourteen theme.


    Micheal
    Participant

    @micheal0424

    I think I have it narrowed down to the s2Member Plugin causing an authority level issue, that is why I can see everything but she couldn’t.

    I thought I had that plugin off but it was the only one I missed.

    Now I have to figure out how to make the adjustment where I need to to get the participant to see it.

Viewing 25 replies - 1 through 25 (of 28 total)
  • You must be logged in to reply to this topic.
Skip to toolbar