Skip to:
Content
Pages
Categories
Search
Top
Bottom

PHP Fatal error in bb-settings.php on line 7


  • lokem001
    Member

    @lokem001

    Hi!

    I did the installation as guided… created a config file…

    So after the creation of a config file, and I reload the page, nothing shows but blank… a big white blank page.

    I get this messege in my apache error log:

    [error] [client 127.0.0.1] PHP Fatal error: Call to undefined function __() in C:\wow1.11\www\bbpress\bb-settings.php on line 7

    Thx for all the help I can get! :)

Viewing 6 replies - 1 through 6 (of 6 total)
  • If you’re installing it locally, it’s worth noting that a lot of people have had problems with it but had no problems on a live server. Or is it a live Windows server?


    Trent Adams
    Member

    @trent

    It seems that you install isn’t liking the syntax of your install. Maybe check out this thread on localhost installs for ideas?

    Trent


    lokem001
    Member

    @lokem001

    Thanks Trent, but that link gave me nothing :(

    Fel64, I don’t really get what you mean with “live Windows server”… anyhow it’s a WindowsXP server, Apache 2.2, PHP5, latest MySQL – all installed on a personal LAN server.

    And the Apache/PHP installation works fine with some other simple PHP applications.

    I also tried to copy an older installation of bbpress that worked fine on a previous WinXP/Apache server, but due to a disk failure I had to format the drive and re-install everything.

    However, that older bbpress turned out with the exact problem (blank page) and the same line Apache’s error.log…

    My guess is something’s wrong with my Apache/PHP installation.

    Thx,

    lokem


    Sam Bauers
    Participant

    @sambauers

    Looks like a problem with gettext. Search around for hints on enabling PHP’s gettext functions. I think it’s just a matter of moving an extension DLL on windows or something, it’s long enough since I administered a windows machine that I have forgotten – and I’m not going back – so that’s all te help I can offer. I don’t know why the included php_gettext wouldn’t have kicked in though.


    lokem001
    Member

    @lokem001

    I have an /ext/ folder, with all the extensions including php_gettext.dll.

    In php.ini the extension_dir is set to “C:/Program/PHP/ext”, which is correct.

    By using phpinfo(); I can see that gettext is enabled.

    Further, I have tried re-installing PHP.

    Still, I get the same results as above. Any help?


    lokem001
    Member

    @lokem001

    After hours of troubleshooting I finally got to the problem, by luck!

    While going through the extensions in php.ini, I noticed the php_mysql.dll was disabled. So I enabled it, and bbpress started to work out great!

    So it didn’t really have anything to do with gettext, but without that tip I guess I wouldn’t have checked the extensions at all!

    Thanks for the help, all of you!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.
Skip to toolbar