Skip to:

PHP 5.3 Error

  • Matoca


    I have been getting a 500 Server Error when I try to view a certain page of replies in the dashboard.
    500 Server Error
    A misconfiguration on the server caused a hiccup. Check the server logs, fix the problem, then try again. URL:

    I worked with my hosting support and allowed them into the wp dashboard to help. The issue is that last night they deleted php ver 5.3 from their servers. This was his response:
    “From the errors its throwing it does need 5.3, and no, I tried 5.2, and 5.4 both are failing.”

    I asked him why they removed 5.3 and this was his reply:
    “It lost support by the php developers back in march of 2013:
    We’ll be removing 5.2 at some point in the near future as well as it lost support years ago. We’re going to keep 5.4 around, and introduce 5.5 as an option soon as well.”

    I can still see the replies on the forum, I just can’t open that page in the dashboard to edit them. I can seem to open other pages of replies but can’t be sure of the extent of this yet.

    What impact is running on php 5.4 going to have on working with bbPress?
    Thank you, Matoca

Viewing 2 replies - 1 through 2 (of 2 total)
  • I am pretty sure this is NOT a PHP issue, WordPress only requires PHP v5.2.4 or above and bbPress follows WordPress’ requirements.

    As to future versions of PHP v5.4 & v5.5 are supported and the only known issue I know of at the moment is a MySQL warning with PHP v5.5.

    I am still not sure what the issue actually is but I follow it up further with you on the other thread where I have already written a reply.



    I have been around with bluehost about this PHP version and a few problems for several months now. I went to install Quick Cache and discovered that I needed at least PHP 5.4 or 5.5. So after reading about the pluses and minuses of each version I went with PHP 5.4 (FastCGI) and eventually added gzip compression as recommended by QC. It was an amazing difference in performance. (Compression 70.4%)

    Sometime after this I was trying to install a second installation of simplephpchat from MOJO, Simple Scripts. I was told that it requires 5.3, not 5.2, nor 5.4, but 5.3. Apparently I had installed it when php 5.3 was installed, but since it requires php 5.3 and that is no longer available, I couldn’t install another instance. Honestly, I just wanted a simple php chat room, nothing fancy, and so I was left with nothing to chose from. Apparently a number of the Simple Scripts WP plugins require 5.3. Eventually I tried X7chat and that works ok under PHP 5.5.

    So this seemed like it was just one more problem to resolve between PHP versions, I didn’t question what he was telling me this morning. I have felt that if so many products were dependent on 5.3 maybe they should just leave it available a while longer? I understand the unique differences between HTML and HTML5 and CCS2 and CSS3, but I don’t know what the unique differences are between PHP versions. It seems like a pretty straightforward language to me?

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.
Skip to toolbar