Skip to:

"No Topics" message showing in single forum to non-admin accounts

  • David


    After creating a new forum “NFL” (as a forum, not a category) and entering a couple test topics via the admin panel it displayed on the forum index (archive) correctly and correctly showed that the forum contained 2 topics. From the admin account and a public account I could read those topics on the front-end just fine. However, from a non-admin account the single forum index (forums/forum/nfl) displayed the notice that there are no topics yet. When I created a topic from the front-end form as a non-admin it would take me to a 404.

    I’ve read about the need to resave the Forum Settings page at different stages so I tried that but it made no difference. I also tried renaming the slug to nfll but it didn’t fix things either.

    I’ve since deleted the forum and recreated it which took care of the problem but I’m wondering if there is an issue that comes up when Topics are added to a forum from the admin (or maybe the first Topic of a forum?), or if something else triggered the problem.

    Anyone else familiar with this?

  • You must be logged in to reply to this topic.
Skip to toolbar