Skip to:

No Stylesheet

  • I recently installed bbPress to localhost to experiment before I put it on a live site. Strangely, the stylesheet was being ignored. Looking at the source brought up this:

    <link rel="stylesheet" href="http://localhost#support/bb-templates/kakumei/style.css" type="text/css" />

    Edit: OK, I can’t seem to type a backslash here, but the # symbol in the above code snippet is actually a backslash (opposite of /)

    I have no idea why the slash after localhost is backwards. It appears correctly in all other locations. For what it’s worth, here is the relevant section of my config.php file:

    // If your bbPress URL is , the examples would be correct.
    // Adjust the domain and path to suit your actual URL.
    // Just the domain name; no directories or path. There should be no trailing slash here.
    $bb->domain = 'http://localhost'; // Example: ''
    // There should be both a leading and trailing slash here. '/' is fine if the site is in root.
    $bb->path = '/support/'; // Example: '/forums/'

    Any help?

Viewing 11 replies - 1 through 11 (of 11 total)

  • chrishajer


    Does this topic help at all?

    Hi chrishajer,

    It seems like a similar problem, for sure. Is there a fix for it? I’m using version 0.8. According to that thread, this issue should only occur in older versions.

    Incidentally, I’m not using any custom templates or plugins. It’s an “out-of-the-box” install of 0.8.



    I don’t think there was a solution on the other topic: I believe it ended with a question to try something else (different plugin versions) which would not apply in your case.

    What operating system are you using? Maybe I can do an install on localhost and see if I can recreate your problem.

    I’m surprised it works on localhost actually, but Trent said there are lots of successful localhost installs. Can you install into a different folder on your web host and see if it works there? I know there might be an issue, but if this is for experimentation, why not perform the experiment on the hardware it will eventually go live on?

    If your operating system is a Linux variant (I am using Kubuntu Edgy), I can do an install here and see if I have the same problem.

    Hi chrishajer,

    Thanks for the help. I’m using Windows XP Home with SP2 installed and XAMPP as the web server.

    I tried a test installation on a private subdomain on the actual web host hardware and it is indeed working there, but since I’d ultimately like to try developing themes and plugins, it would be a lot more convenient if I could work on this locally. (I actually run a complete mirror of my site locally for development purposes. Since the site is somewhat complicated as a whole, it’s important for me to test everything on the non-live site before I flip the metaphorical switch.)

    The problem with localhost will be addressed in the next version for sure, but it always helps to check out this ticket for reference to any problems with localhost installs:

    Referencing this file:


    Thanks, Trent. I’ll give the plugin fix a shot and keep an eye on the ticket. :-)

    Hi Trent,

    I’m having the same issue with marky. I’ve tried to look at ticket 575 but it’s not there anymore.

    I would appreciate any help. Thanks.




    I’m having the same exact problem, with the same configuration: Win Xp with SP2 + Xampp.

    Installation went fine, WP users (with the locally installed WP) are recognized, even the french translation file works.

    The path to my stylesheet seems fine, I checked the source. But it won’t work.

    I didn’t get how to fix it. I saw the PHP code but it doesn’t tell WHERE to put it. If anyone could tell, that would be great.


    EDIT: I’ve tried to figure it out by myself but it didn’t work out.

    I added the function in the “functions.php” file, and the add_filter in the “default-filters.php” file, both files being in the “bb-includes” folder.

    What did I do wrong?



    If the stylesheet path is correct, you do not have the same problem. It should not contain at all.

    The code should maybe go in /my-plugins/.



    Actually I made a mistake, it’s not the good path.

    Anyway, it’s only a local problem. So I just replace the php function with the exact local URL (http://localhost/…/style.css) in the header.php file.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.
Skip to toolbar