Skip to:

Next page not working

  • Hi all. I tried searching for this but couldn’t find anything. If this have been resolved, please link me. Thanks.

    I’ve got a navigation problem. The Next link doesn’t work. I’ve got permalinks working, so it wants to send me to /forum/forumnam/page/2/ but all I get is a reload of the same page.

    Any ideas what might be causing this?

Viewing 7 replies - 1 through 7 (of 7 total)

  • chrishajer


    Can you share the URL? It sure sounds like a permalinks problem, but you say those are working fine.

    Actually, no, I can’t share, it’s a closed forum for a client’s editorial staff. I might get them to move another domain to the server so that I can set it up and replicate the problem there, though?

    And yes, they are working perfectly fine besides this. I was a bit surprised that they were, actually, since there’s a WordPress MU install on the same domain, but they’re playing nicely, and permalinks worked right away using the standard instructions, didn’t do anything fancy at all.

    (Forum was installed after WPMU if that helps.)

    Any ideas?

    I managed to duplicate the problem on my own project. Take a look, Next link (Nästa in Swedish, way down) doesn’t work. :(


    The forum is installed in /forum. There’s a WordPress MU installation in the root directory, with working permalinks.



    It certainly LOOKS like a rewrite problem. When you click a link that looks like, you are redirected to That to me says it’s a rewrite problem, maybe only when the url contains “page” or something.

    You can try it with mod_rewrite set to false and see if it works properly. If it does, then it’s an issue with the rewrite rules. You could also check the apache logs (if you have access to them) to see how the rewriting is happening and why it’s doing this. It doesn’t result in a 404, it just redirects someplace that’s incorrect. I think that’s because of the rewrite rules. I would try it with mod_rewrite to false and see what happens.

    Good luck.

    Thanks for your input, I’ve resolved it!

    It was a mod_rewrite problem. After disabling it everything worked fine, so I took the long road and went and generated a htaccess file, instead of the one using MultiViews etc. That did the trick.

    Weird though, why shouldn’t MultiViews work with pagination, when it works with everything else?

    Ah well, it’s A-OK now, so thanks for the help! :)

    About MultiViews, I recently re-read FAQ. There is a note for not working MultiViews.

    3. Try it out. If it doesn’t work, your web server does not support MultiViews. Instead, you’ll need to remove that line from your .htaccess file and replace it with the several lines bbPress generates for you when you browse to your bbPress installation’s /bb-admin/rewrite-rules.php.

    Maybe you can try it and let us know if that works?

    That’s what I did, when using the generated bbPress htaccess code it works, but not with MultiViews.

    Thing is, everything worked just fine with MultiViews, except that Next link.

    Ah well, resolved now. Thanks for the help guys!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.
Skip to toolbar