Skip to:
Content
Pages
Categories
Search
Top
Bottom

New users suddenly no longer registered as “participants”


  • Tracey
    Participant

    @traceyrissik

    I have a new website/forum set up at https://freremanu.com/forum/ which has been working fine until the last few days. When I set up test users using the registration form on the side of the forum page, it would correctly set the user roles as “Subscriber/Participant” – but since about a week ago, it is only setting them as “Subscriber”.

    Even if then go and manually change the forum role to “participant”, when I sign in with the test user it says the forum page is “Not Found”.

    I have tried disabling all plugins & checking, but this makes no difference.

    Whether I register through the Forum widget (sidebar) or through the WP Login page, the result is the same – the role is just set to Subscriber.

    Does anyone have any idea what has gone wrong, and more importantly, how I can fix this?

    thanks in desperation!
    Tracey

Viewing 5 replies - 1 through 5 (of 5 total)

  • Tracey
    Participant

    @traceyrissik

    (Update : If I manually also reset the defaults for access, things work ok – but the problem remains that it’s not happening automatically, as it used to)


    Robin W
    Moderator

    @robin-w

    users get the ‘participant’ role when they first log in (if that is the default role set for them)

    so if you set them up, then you will only see subscriber until they have logged in for the first time.

    I just registered on your site and got access to the forum fine


    Tracey
    Participant

    @traceyrissik

    Hi Robin,

    Thank you thank you thank you! I’m so grateful – that was one thing in all the testing I did that I didn’t notice happening…

    I think I got a bit panicked as there have been a lot of users subscribing (I suspect spam ones though, as the email addresses & usernames all have almost identical formats) and none were participants…

    You time & help is really appreciated!
    thanks
    Tracey


    Tracey
    Participant

    @traceyrissik

    (PS I’ll delete your user from the forum so it’s not left lying around)


    Robin W
    Moderator

    @robin-w

    no problem, it’s far from obvious !!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.
Skip to toolbar