Skip to:

New installation – cannot login

Viewing 11 replies - 1 through 11 (of 11 total)
  • On the WP blog I have the plugin “Limit Login Attempts” installed ( I have tried turning that off, to no avail.



    Do the errors go away if you use English instead of German?





    This comes up fine:

    I had the problem when I tried to log in. Sounds like something with the integration is not working maybe? Invalid key or something?



    There is a problem in your bb-config.php, most probably in the first line.

    Normally, HTTP-requesting bb-config.php should not create any output. But try

    and see the strange “”. I cannot get, what the problem exactly is, but it is the bbPress configuration file for sure. After login, bbPress tries to set a cookie. This is done by sending an HTTP header. But if there is any output before the PHP header () invocation, PHP sends a generic header, which lets the cookie fail. Result: you can not login.

    Ich hoffe, es hilft ein bisschen — und sorry für mein mieses Englisch ;-)

    Oh, ich vergaß — Oh, I forgot

    If you want a german language file for bbPress 1.0.2 (with the formal “Sie”), take my translation — Wenn du eine deutsche Sprachdatei für bbPress 1.0.2 haben möchtest, nimm meine Übersetzung.



    nice work, goebelmasse.

    I’m already using your translation goebelmasse, thank you. Just turned it off for testing.

    These strange characters you pointed out show up even if the content of config-bb.php is nothing but a PHP start and end tag. (I have no blank lines before or after the PHP tags.)

    I think it must be some problem with the keys. I basically used all the keys from the wp-config.php with “BB_” added to the start of the keyname.

    define(‘BB_AUTH_KEY’, ”);

    define(‘BB_SECURE_AUTH_KEY’, ”);

    define(‘BB_LOGGED_IN_KEY’, ”);

    define(‘BB_NONCE_KEY’, ”);

    define(‘BB_AUTH_SALT’, ”);

    define(‘BB_LOGGED_IN_SALT’, ”);

    define(‘BB_SECURE_AUTH_SALT’, ”);

    The keys I use are all from the WP generator:



    Oh, that’s weird, time for a deeper examination…

    I get the output from bb-config.php as a local file with wget and cat it to my console on my UTF-8 linux system. It looks like an empty file, but it has a size of three bytes. And than I remembered about Unicode and typed od -x bb-config.php, which results in

    bbef 00bf

    And then I began to understand.

    The first three bytes ef bb bf (for normal reasons least byte first on intel platforms in inverse order to make it not too easy to understand) are the byte order mark for a UTF-8 encoded textfile. But for PHP, they are simply characters.

    Some informations about the BOM in german language

    Your text editor saves the file as UTF-8 and writes a byte order mark at the beginning of the file, and these three bytes do cause the strange error. Look in the documentation of your editor to find the setting for the file storage format, and if in doubt, simply save the bb-config.php as a plain ASCII file instead of Unicode or UTF-8.

    Ich hoffe, jetzt hilft es wirklich ein bisschen weiter. So ein Problem ist richtig arg, da kommt man nie drauf, wenn man kein Glück hat…

    (Okay, it is an english forum here: I hope this times it helps a little more. This type of problem is a hard one, something you never think about and find it only by chance…)

    Holy cow, good catch! It’s working now. Thank you again.




    I wrote a detailed description of the problem in german language — ich habe das Problem ausführlich in deutscher Sprache beschrieben:

    Ah cool, that might help some people.

    I use Notepad++ by the way and have it set to save in UTF8 by default. It’s easy enough to change though.

    Once you know the problem that is.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.
Skip to toolbar