Skip to:

My admin page displays, but nothing works!

  • Hi

    I was hoping someone could point me in the right direction to solve this. I installed the forum at and got the message that the instal was successful, but when I try to open the page at (the URL I got via e-mail) I get a 404 error. I can open the admin page at but nothing works. The only thing weird about the instal was that I had to change the location of the MySQL database from localhost to the name of a different server, it seems my ISP (GoDaddy) set things up a little different then most. Can anybody suggest a fix?


Viewing 4 replies - 1 through 4 (of 4 total)

  • chrishajer


    It looks like all the files were not uploaded properly. For example, the stylesheet is missing:

    Or possibly, you have pretty permalinks or slugs turned on, and they’re not supported by your host (very common with GoDaddy and Dreamhost, I think.) Modify this line in your config.php from 'slugs' or true to false like this:

    $bb->mod_rewrite = false;

    If all the files were uploaded properly, I would guess this is your problem.

    Hi Gang

    Thanks for the reply chrishajer, but the suggestion did not work :( I’m wondering if I’m putting things in the wrong directory? The config-sample.php file references the forum address as “”. I’ve tried putting the bbpress installation at the root level as well as in a folder called forums, but I still have the same problem. When I set-up the forum how should I handle line 17? Should I leave everything at the root level or should I create a new folder and put the instal there and have line 17 point there? Does an example file structure exist in a FAQ anywhere?

    BTW, the style sheet and such exists, it is however not being used.




    Well, let’s see. Your forum is in a directory called bbpress:

    So line 17 in config.php should look like:

    $bb->uri = '';

    Create a folder, call it whatever you want. Just be sure you access the URL with that folder name, and be sure line 17 has the same folder name. That’s really all there is to it.

    It works!

    Thanks Chris! It seems I was uploading the contents of the bbpress folder *and* the bbpress folder itself to the website. Once I uploaded just the contents of the bbpress folder it worked fine. Oh well, live and learn.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Skip to toolbar