Skip to:

Missing Admin menu items

  • Jeff Starr


    Hi, I just updated to bbPress 2.3 and all of the admin menu items completely vanished. The following menu items are suddenly missing after upgrading to bbPress 2.3 and making no other changes whatsoever:


    ..all are missing after updating to 2.3, so I had to roll back to 2.2.4, and they once again are displaying normally.

    Additionally, I also noticed that the “Edit” link was missing from all forum posts, even though I was logged in as Admin. Rollback to 2.2.4 resolved this issue as well.

    I hope this helps in some way, sorry I don’t have time to troubleshoot further.. already spent WAAAYY too much time on what should have been a simple update. So this is just an FYI, hopefully it helps.

Viewing 7 replies - 1 through 7 (of 7 total)

  • hllorens



    Just installed bbpress today and had exactly the same problem.
    In my case, I realized that was a problem with Advanced Access Manager Plugin.

    If you have it installed go to capabilities and add to the Admin/Super-admin role the capabilities to manage forums/topics…

    Hope this helps!



    I had the same problem but I was able to get it to appear just by playing with these settings under Settings > Forum.

    Anonymous posting
    Default user role (move the role to keymaster and then switch it back)
    Auto role

    I can’t tell you what order I did them in (because I can’t remember) but turning them on and off seemed to do the trick for me.



    I was having the same issue, it was Members plugin by Justin Tadlock that fixed the problem. I had it activated previously to fix a role permission, I’m guessing bbPress updated roles or something, once I added them and clicked save and refreshed the forum admin menu displayed.

    I’d suggest doing the same if you have any role manager type plugins installed and experience this issue.



    I have the same problem with version 2.3.2. After updating the menu items for topics, forums etc. are missing. All new posts get blocked by the spam settings and I do not know how to activate them without the menu item.
    I played around with Settings > Forums as jonboldendesign wrote. The items appeared. Then I put the settings back to default. Now the menu items are gone again and I do not have the permission to access the Settings > Forums page (as WP admin!) Great stuff… 🙁



    After about two hours I could find a solution for me. It turned out that current_user_can( 'bbp_forums_admin' ) resulted in false. This is why I could not access the menu or even write replies although the user admin showed me as WP administrator and forum keymaster.

    I wanted to check why my user did not have the capability “bbp_forums_admin” and installed the plugin Capability Manager Enhanced. After activation of the plugin everything worked fine again. All menu items showed up and I could post replies. Maybe this plugin fixed what bbpress messed up after updating to 2.3.2…

    Jeff Starr


    Just to follow up with this.. I also tried jonboldendesign’s suggestion and it worked with bbPress version 2.4.1. Here is what I did immediately after upgrading from v2.2.4:

    1. Enable “Anonymous posting”, save changes.
    2. Disable “Anonymous posting”, save changes.
    3. Enable “Auto role”, save changes.
    4. Disable “Auto role”, save changes (optional).

    After the 3rd step all three menu items (Forums, Topics, Replies) are showing. Note that just upgrading to 2.4.1 was enough to get the Forum menu item to show, but the other two (Topics, Replies) only showed up after the first three steps.

    Thanks to jonboldendesign and everyone who provided feedback on this 🙂



    Hi folks,

    Same problem with me, new BP install, new BBPress install but no bbpress menus in my dash at all.

    In my case it did turn out to be a plugin clash, and in case it should help anyone else, “WP Survey And Quiz Tool” plugin conflicts. Disable the quiz plugin, and the bbpress menus magically appear. I did manage to set up my forums, then reenable the quiz plugin and they both appear to function correctly.


Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.
Skip to toolbar