Skip to:

Keymaster Lost after integration / WP 3.0.1 – BP – BB

  • Hey there I had an integrated WP + BB website, then I installed also BuddyPress and used it for a while, everything integrated, using BB as forum engine for BP too.

    I then decided to get rid of BP and now I just want to go back to my initial configuration of WP + BB, using the same old DB that still contains BB forum posts.

    Everything is working and the user integration still works, but I have the damn “keymaster lost” problem: My admin user can’t access the BB Admin in any way.

    I’ve tried all the solutions proposed around here and on the internet, changed my capabilities on the DB to a:1:{s:9:”keymaster”;b:1;} etc.. no way.

    If I try to access the /bb-admin area it redirects me to the root.. and there’s no “admin” link near my profile name.

    My tables have different prefix:

    $bb_table_prefix = ‘wp_bb_’;

    I just have WP_USERMETA table as the integration is already done..

    What’s the meta key I have to set?!?

    I’ve tried “wp_capabilities”, “wp_bb_capabilities” and “bb_capabilities”, but no-way.. no admin access for my user.

    I’ve also tried to create new users and assign the keymaster.. same thing, no admin access.

    Maybe Buddypress changed something that I have to reset?

    Please help! :)

Viewing 5 replies - 1 through 5 (of 5 total)

  • kevinjohngallagher


    This version (original) of bbPress isn’t compatible tiwh BuddyPress. I’m afraid you have to ask on the BuddyPress forums for how they fix these things :(



    wp_ = wordpress

    wp_bb_ = bbpress

    admin ID = 1


    1 wp_capabilities = a:1:{s:13:"administrator";b:1;}

    1 wp_bb_capabilities = a:1:{s:9:"keymaster";b:1;}

    logout, login.

    Zaerl, already tried that way, but no luck.. still no admin link nor admin access, here’s my wp_usermeta table:



    So maybe BuddyPress has done something weird with your DB. BuddyPress + bbPress = bad.

    I have the same problem, I just haven’t used BuddyPress. Fresh WP 3.0.1 multisite and bbPress installed from svn trunk (as suggested by friend). I’ve integrated bbPress with WP and since then I can’t go to /bb-admin/ (being redirected to the root of the forum) nor I can reply on default topic (created by installer). I’ve checked with other users and everyone can log in but noone can reply or create new topic.

    I’ve checked the database and wp_roles_map in bbPress db is:

    array (

    ‘administrator’ => ‘keymaster’,

    ‘editor’ => ‘moderator’,

    ‘author’ => ‘member’,

    ‘contributor’ => ‘member’,

    ‘subscriber’ => ‘member’,


    In WP database (table wp_usermeta) wp_capabilities for my user:

    array (

    ‘administrator’ => ‘1’,


    There is also wp_2_capabilities field which contains same serialized array.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.
Skip to toolbar