Skip to:

Key Master Doesn’t Have Permission to Add Forum

  • Install worked great, everything good. I’ve logged in as admin, assigned Key Master, and lo and behold I can’t create a new forum. I get the message ‘you don’t have permission to do that’. The admin account was first created in the wordpress mu install.

Viewing 14 replies - 1 through 14 (of 14 total)

  • _ck_


    This might be a role assignment issue and you might have to edit the mysql tables by hand in phpmyadmin to fix it…

    added – or try this?

    Hi _ck_, I’m an associate of livwest who posted this. I’ve tried various things. I found the user metadata. The admin account has the keymaster specification and can get to the dashboard. But it cannot add a forum. I added the magic bits to my own account directly in MySQL and became a keymaster too. I show up in the list of keymasters. But I don’t have the right to change a forum either.

    This is a wpmu and bbpress mashup. It all went fine at install. Where is the data controlling rights to add forums stored?

    Just installed bbPress, and experiencing the exact same problem. Normal installation of WP 2.3 (latest version). No clue what might be wrong either.

    Making another user KeyMaster works however. So as a workaround I’ve registered a “dummy” to use for this only. Awesome.

    Edit: It turns out my “normal” account doesn’t have permission to edit tags either.



    If creating a new user and assigning them as a Keymaster works, then it’s obviously a problem where the user in the existing WP/WPMU table doesn’t have the correct role set by bbpress when it installs/configures itself.

    For those that know what they are doing, you can examine the new, working admin user under phpmyadmin and compare them to the old non-working admin and see what’s different. I think roles are stored in the usermeta?

    Unfortunately I personally don’t have the time/setup to try to hunt down the exact bug with this right now, but I bet there are plenty of people on those similar threads with experience who can tell you what’s wrong.

    (also unfortunately this is yet another demonstration of bbpress integration weaknesses that must be fixed before it will be widely accepted by existing WP users. WP has a role editing table in the admin options, or might be a plugin, maybe that can be ported?)


    Thanks. I just tried blowing away the bb_ tables and repeating the install. The problem persists so I agree with your conclusion that the problem lies with the rights in the wp admin role. I will continue to seek an answer and share it when I find it!

    I am totally comfortable hacking around in the database. I back things up first and can always restore. So I will try that route next.


    OK I fixed it. It looks like we took some bad advice. There was a post saying to make wpmu and bbpress get along I should add:

    if ( isset( $bb->wp_table_prefix ) ){

    $bb->usercookie = ‘wordpressuser’;

    $bb->passcookie = ‘wordpresspass’;


    to the config.php

    That is the code that was messing things up. Without it admin works fine as keymaster and I see no other problems yet.

    I have this problem as well, but haven’t added the code mentioned above to my config file. I’ve added another user as a key master, and that one can add forums, but I’d really want the original admin to be able to do that. Any suggestions?

    Well, this is just plain weird. Still haven’t been able to fix it for my original WP admin account (the dummy one holds up however), but I experienced something even weirder today.

    Was logged in, adding some tags to a thread, and whoops, after being able to add one just fine, it gave me the “No permission” message when I tried to add a second.

    Go figure.

    Hope someone is able to work out a fix for this. Haven’t added any code to the config.php file.

    More issues along the same lines here:

    Key master is not allowed to add forums

    Can’t add additional tags to post

    I can confirm that I am using the “use display name” plugin mentioned in the first thread, and deactivating it DID fix the issue.

    I had the same problem. In wordpress I had changed my display name to something other than my login name. This was the problem, when I changed it back to match my login name, it worked.

    Having the same issue – first tag added ok. Second tag said gave me the permission error.

    This reminds me of the ajax issue with WP. Is there any chance it’s related?

    Creating a second Key Master did not work for me.

    Help? Any ideas? Neither of my key masters can create tags, etc.

    2.3.3 WP, 8.3.1 bbPress sharing user table.

    today’s upgrade fixed permission error for me. THANK YOU!!!

    So the new version of bbpress fixed the issue?

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.
Skip to toolbar