Skip to:
Content
Pages
Categories
Search
Top
Bottom

Issues with Edit buttons and Topic Visibility


  • jacuzzy
    Participant

    @jacuzzy

    Couple of issues… I’m not sure what version of wordpress is being run (as ridiculous as this sounds. I came in halfway on a project, and another developer I got to look at the site also could not tell me), but it is something before 3.8. The bbPress version is 2.4.1. Site only shows a splash page to non-members, and registration is blocked, so a link to it would be pointless.

    1) Hitting “Edit” on a topic as administrator puts the HTML for the editor into the text box of an editor. If I hit “submit” without changing the contents, it edits the topic, but includes the edit form in the topic. Here is a screenshot. Clicking on submit in the resulting form within the topic does the edit as it should. I am not sure if this happens for regular members… see issue 3.

    2) Clicking “Edit” on a reply results in the following message:
    “Thereโ€™s nothing here.

    If there were posts in the database, youโ€™d be seeing them. Try creating a post, and see if that solves your problem.”
    When I go to the dashboard > replies, I can clearly see all the replies listed there.

    3) I realize this is a known issue, but I could not find a good resolution for my case. Topics are not viewable by regular members, but all replies are viewable. Anyone with bbPress moderator role and above can view topics just fine. s2member is being run on the site, and from what I understand, s2member admins get bbPress moderator roles, while bbPress moderators get s2member admin roles. I have tried disactivating the s2member plugin, and the topics show up fine then. I can’t ditch s2member, but obviously am not going to give every member admin/moderator roles just so they can see topics. In fact, every member should only be a participant. There should never be any need for moderators (save for the actual admin). I’ve checked visibility on the forums, and everything is set to public.

Viewing 8 replies - 1 through 8 (of 8 total)

  • Stephen Edgar
    Keymaster

    @netweb

    Firstly why not update to WordPress v3.9.1 and bbPress v2.5.3?

    The ‘edit’ issue is most likely a plugin conflict, start deactivating plugins one by one until the issue goes away then enable the other plugins you disabled and research any known issues with the plugin causing the problem.

    As to the s2member issue, you are going to have to meticulously go through each of the role settings and confirm what permissions are be given to each s2member and bbPress roles to work out whats what.


    jacuzzy
    Participant

    @jacuzzy

    Unfortunately, whether we should upgrade or not is not my call to make. At the advice of another developer, my project manager has decided that we will not be updating WordPress. At the advice of yet another developer, I have been warned not to update bbPress either. Sorry. I’m just a measly intern developer with no say. ๐Ÿ™

    I was speaking with one of the aforementioned developers today, and he suggested that it the ‘edit’ issue (as far as the HTML in the editor goes) might have to do with Thesis. I’m going to look further into bbPress-thesis compatibility issues, but would you happen to know anything offhand about that? I do have the bbPress-Thesis compatibility pack plugin installed.

    As for s2member, I have tried various combinations of role settings, but the issue still remains that a member has to either have highest level (admin) role in s2member or moderator or higher role in bbPress in order to view topics. All replies are visible to all roles, s2member and bbPress. I realize I might be starting to get out of scope of this forum, but there is a full post here that describes the roles as they interact between s2member and bbpress. Is the only way for me to work with bbPress and s2member to customize the roles? I’d hope for a simpler workaround if possible…


    Stephen Edgar
    Keymaster

    @netweb

    Oh! Ok, strange decision not to update where said updates may actually fix your issues so I’m not sure what we can do here to help out and I’d suggest you mention that if you are being asked to ‘fix things’ that could have already been fixed in newer versions, not specifically saying the issues have been fixed but there are vast improvements nevertheless.

    I am not aware of any specific Thesis compatability issues, might be something to research through the Thesis community support forums, again you might find the latest Thesis compatability pack supports bbPress 2.5.x and have to roll back a version that works with bbPress 2.4.x.

    I haven’t used s2member so I really cannot advise how best to do anything with it ๐Ÿ˜‰

    You could take a look at this plugin that when viewing a users profile in the backend will show you each of the bbPress capabilities assigned to a user that may help you narrow down the issues.


    jacuzzy
    Participant

    @jacuzzy

    Just got a solution to issue 3 (the topics/first post not showing).

    Turns out s2member was the culprit. A setting in s2member > restriction options > alternative view protection, unchecking only the first check box, “Filter ALL WordPress queries; protecting all Alternate Views” seemed to do it. Now I’ll have to figure out what this implies for me in terms of protected content, but that’s an issue for s2member forums. This piece is resolved. I’ll go and make posts in the other threads where I saw this issue “unresolved” as well so more people can see it.

    I’ll keep looking into the edit issues and reply if I find anything. Thanks for your help Stephen. ๐Ÿ™‚


    Stephen Edgar
    Keymaster

    @netweb

    Cool, glad you found a solution but just FYI, please don’t bump any topics older than 12 months ๐Ÿ˜‰


    jacuzzy
    Participant

    @jacuzzy

    Alright, did not bump any topic > 12 months, and will not do so.

    So here’s where I’m at: Figured out a fresh bbPress install from 2.1 and above has issue 1 resolved for me.
    But with bbPress 2.4.1, the version I’m running, I still needed the most updated bbPress-Thesis compatibility pack to fix issue 2. Unfortunately, the bbPress compatibility pack only goes up to 1.2.4 (what I’m now running), and was only actively being updated until bbPress 2.1 or so.
    I tried running a clean bbPress 2.5.3 (no compatibility pack), and issue 2 occurs. Adding the compatibility pack breaks 2.5.3 completely (and I’ve not invested time looking into code).

    What’s happening now is that issue 1 (HTML for editor inside editor when editing topics) is now occurring when I try to edit replies. So I’m still having issues with the visual editor.

    What puzzles me is that in the Thesis forums, some other users talked about having troubles with their visual editor as well, even with the latest (1.2.4) compatibility pack. But supposedly, someone found a fix and crossposted it in this topic and in the Thesis forums. In the Thesis forums, he claims that this fix is implemented since bbPress 2.2, but I’m running 2.4 and still having issues with the editor?

    The code fix in the above link also does not work for me, since in 2.4.1, bbp_replace_the_content is no longer a method that exists in theme-compat.php. Considering that the symptoms of my current issue seems to be the same as original issue #1, I would think the fix would have something to do with a similar problem where a function is being called twice, but have no idea where to begin looking. Any ideas?


    jacuzzy
    Participant

    @jacuzzy

    Excuse me – didn’t occur to me that “visual editor” was referring to TinyMCE. I do not have TinyMCE running on my bbPress, just a regular editor like the one in this forum.


    Stephen Edgar
    Keymaster

    @netweb

    I’m really not sure what else I can suggest, my recommendation still stands to upgrade WordPrress and bbPress to the latest versions.

    The only other suggestion that ‘may’ work when using bbPress 2.5.4 without the Thesis Theme compat is to add a bbPress wrapper template in your theme directory that may stop issue 2 from occurring.

    Try creating a file in the root of your theme called bbpress.php and putting the following code into it

    
    <?php
    /**
     * bbPress wrapper template.
     
     */
    
    get_header(); ?>
    
    <?php while( have_posts() ): the_post(); ?>
    
    	<?php the_content(); ?>
    
    <?php endwhile; ?>
    
    <?php get_footer(); ?>
    
Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.
Skip to toolbar