Skip to:
Content
Pages
Categories
Search
Top
Bottom

Issue with Polylang


  • xxreef
    Participant

    @xxreef

    Hi all,
    first thanks for this plugin.

    I have a problem on Polylang, a widget to manage the site in multilanguage, the base features are all supported, but when in the secondary “italian” language I click on “modifica” (Edit) the page response with 404.

    The Polylang works with the introduction of /it/ url after the domain and before the rest of uri.

    This problem don’t exist on main English language.

    Bye Renzo

    The page I need help with: https://www.mischianti.org/it/forums/

Viewing 13 replies - 1 through 13 (of 13 total)

  • ecollart
    Participant

    @ecollart

    Same problem for me, also using Polylang !

    If the admin bar is visible on top, the Edit menu from there brings you in the backend and you can edit the topic.
    The link is http://domain.com/wp-admin/post.php?post=9050&action=edit

    But the Edit menu from the Subject (admin links) give a 404 error
    The link here is http://domain.com/fr/forums/topic/admin-gui/edit/

    Very frustrating especially that the top admin bar is not visible for regular forum participants.

    Thanks for your help

    Eric Collart


    Robin W
    Moderator

    @robin-w

    so I’m presuming that

    http://domain.com/forums/topic/admin-gui/edit/

    would work ie it is the ‘/fr’ that is the problem ?


    Robin W
    Moderator

    @robin-w

    and have you added topic, reply and forum as custom post types in the polylang settings


    xxreef
    Participant

    @xxreef

    Hi,
    in polylang settings the url is set to change with language, bbpress work for all situation (topic post reply) but the edit and other link in the upper bar not work.

    polylang settings

    this is the default configuration for polylang.

    With the flag “Hide URL language information for default language” allow to work for the default language (not use /en/).

    I try to add a rewrite rule to htaccess without success.
    https://stackoverflow.com/questions/70142230/why-my-additional-rewrite-rule-is-ignored

    Bye Renzo


    ecollart
    Participant

    @ecollart

    Hello Robin,

    Thanks a lot for your help

    In my case, all forums, topics, responses and keywords are checked in Polylang settings.

    Removing the /fr doesn’t solve the problem.

    Eric


    Robin W
    Moderator

    @robin-w

    so typing for instance

    http://domain.com/forums/topic/admin-gui/edit/

    in the url does not work either?


    Robin W
    Moderator

    @robin-w

    and are you on ploylang pro?

    I can see in settings options for ‘share slugs’ and ‘translate slugs’ that might be needed (or might not be!) and need the pro version.

    and have you raised this issue with polylang ?


    xxreef
    Participant

    @xxreef

    Hi robin,
    in my situation for the default language
    http://domain.com/forums/topic/admin-gui/edit/
    work with flag “Hide URL language information for default language”,

    but for the others language the rewrite rule is triggered for edit, and add /it/, and 404 is raised.

    Bye Renzo


    ecollart
    Participant

    @ecollart

    Hello Robin,

    I raised the issue with Polylang today as well but no answer yet from there.
    I am not using the PRO version.

    The http://domain.com/forums/topic/admin-gui/edit/ doesn’t work at all for me but I didn’t try hiding URL language information for the default language.

    The problem looks consistent.

    Eric Collart


    Robin W
    Moderator

    @robin-w

    ok, as I’m not running polylang I can’t really help further.

    I have no doubt it can be fixed, but not by me 🙂

    But I cannot see that anyone else has had issues with this – not saying that it does work for others, just that I cannot find anyone reporting that they have had issues.


    xxreef
    Participant

    @xxreef


    Robin W
    Moderator

    @robin-w

    it looks like the ‘free’ version does not have support – few threads are answered – that is of course the plugin authors choice, but suspect you might need to upgrade to pro to get help on this.


    xxreef
    Participant

    @xxreef

    Mmmm.. It is a little scam, I believe that the features we need are hidden as support for REST calls

    Polylang scam feature

    I think the only solution is to change htaccess file with a rewrite rule to bypass the add of language in the url.

    Bye Renzo

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.
Skip to toolbar