Skip to:

Internal Server Error creating new post

  • Peter Hardy-vanDoorn


    WP 3.7.1, BP 1.8.1, bbPress 3.4.1. Forum is within a Group.

    I’ve recently been seeing Internal Server Errors when trying to make new forum posts and replies. After clicking the Submit button it takes about 40 seconds and then the error appears. Interestingly, the UTL in the address bar changes to that of a recent post.

    I have checked the server logs and see these 2 lines:

    [warn] mod_fcgid: read data timeout in 40 seconds
    [error] Premature end of script headers: index.php

    This is a recent development and, to the best of my recollection, I haven’t changed anything.

    Any insights would be much appreciated.


Viewing 3 replies - 1 through 3 (of 3 total)

  • Stephen Edgar


    I’m not seeing this on any of my installs, try running the ‘Repair BuddyPress Group Forum relationships’ repair tool

    I am not that familar with mod_fcgid but a quick search landed me here if that might help

    Peter Hardy-vanDoorn


    Hi. Thanks for the input, but I have already tried that! Tried again just now and got ‘Complete! 0 groups updated; 0 forums updated; 0 forum statuses synced.’ and it made no difference.

    It seems to be a script timeout, but that only really diagnoses the symptom, rather than the cause. A script should not take more than 40 seconds to execute really, so I need to identify what is causing the slowdown.

    Needles & haystacks, I’m afraid – unless anyone out there knows where to point me!

    Stephen Edgar


    The only other thing I can think of is switch to the Twenty Twelve theme, disable all your plugins and go for a look around your site. If you don’t see the issue elsewhere now enable BudddyPress, how about now? Next enable bbPress, now? Back to your theme, check again, enable each of your plugins one by one.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
Skip to toolbar