Skip to:

Install glitch: “Username not found.”

  • Installing bbpress to replace phpBB. Got through everything, using the same database as WP, can access the database, WP, Coppermine — everything with my username. It’s correct in config.php. When I enter the username (I get no dropdown), it tells me:

    “Username not found. Go back and try again.”

    I’m no slouch at PHP, and I’ve tried everything.


Viewing 17 replies - 1 through 17 (of 17 total)

  • chrishajer


    Have you tried registering again and logging in as that user?

    I can access everything. I can log in and log out to WordPress, Coppermine, phpMyAdmin –basically everything.

    bbpress still tells me it can’t find the username.

    Try using the username/pass from your WP installation once?


    OK. At the “First Step” in the installation, bbpress asks for the following:


    (form box) <—- there is supposed to be a dropdown here!

    Enter your username below. You will be made the first Key Master on these forums. Leave this blank if you want to create a new account.

    First Forum

    Forum Name:* (form box)

    Description: (form box)

    I get no dropdown. Regardless of what I enter — or even if I leave it blank — it returns, “Username not found.”

    Getting snooty eh? I just suggested that *because* I just did an installation on my localhost, ran into same issue, and then slapped forehead because I forgot to use the WP username during the installation process..

    Whatever.. Good luck with it! .. Tata..


    Not getting snooty… feeling misunderstood.

    As The Animals said, “Oh, Lord, please don’t let me be misunderstood!”

    Kessel, you may need to try this plugin: Usernames I18N Fix. I had the same problem b/c I had a space in my username and it wouldn’t recognize it. I’m not sure if you can install the plugin before you have run the install routine. If not, go back into WP and create a new user with a *very* simple name, give the dummy user admin rights, and then go through the install. Once you’re in, go to your *real* username, make it a keymaster, and if you have this plugin running you should be all set.

    And don’t be such a tool, spencerp. Sheesh. Give the new guy a break.

    Thanks. Got it going, but now I get nothing but 404 pages that insist on a call to “http://ourdomain/forum/install/install.php&#8221; — which doesn’t exist, and doesn’t exist in any of the documents on the site. Hrmmmm…

    This happens when I try to access the main forum page as well as any of the bbpress admin pages. Very strange…



    Do you have an .htaccess that would be rewriting the URLs that way? There is no install directory in the package.

    There is an htaccess file for the nice urls; all it contains is this:

    Options +MultiViews

    Should I disable it?



    You could disable it just to see if that’s the problem. In addition to removing or modifying the .htaccess file, you need to set

    $bb->mod_rewrite = false;

    in your config. That will turn off the rewriting completely. Both need to be working for the pretty permalinks to work (i.e. the .htaccess is present, and the $bb->mod_rewrite = true. It doesn’t work on all servers though. Oddly, it works for my WordPress just fine, but not for bbPress which is in a subdirectory, so I have mine set to false for bbPress.)

    I would disable it for now, just to see if that’s causing your problem.

    No such luck. I have a backup copy of the .htaccess file, so I just deleted it. Then I changed the config to set rewrite to false. It still tries to go to the the install.php file in install folder.

    I think it’ll be a while before my hair grows back. Maybe a little longer for the big patch of skin that came out with it, though.

    And don’t be such a tool, spencerp. Sheesh. Give the new guy a break.

    It appeared that he/she was getting snooty, at least a little bit. However, they weren’t. But either way, at least I didn’t call or refer to him/her as a “tool” as you did me.. I don’t know YOU from Adam.. so get off me.. thx.

    @kessel, my apologizes for misunderstanding you.




    Possible caching by the browser? I can’t think of anything that would cause a redirect like that. You try to visit the forum, and are immediately redirected to /forum/install/install.php? That is weird.

    Spencerp, I was just messing with you. Trying to lighten the mood since people were feeling misunderstood and being labeled as *snooty*. I don’t really think you’re a tool. Sorry.

    Have you had any luck with this Kessel? Did it let you install? Do you have a URL we can take a look at?




    Try “admin”.

Viewing 17 replies - 1 through 17 (of 17 total)
  • You must be logged in to reply to this topic.
Skip to toolbar