Skip to:
Content
Pages
Categories
Search
Top
Bottom

Import from bbPress 1 FAIL


  • TrishaM
    Participant

    @trisham

    I’m starting a new thread for my problem since no one is replying to my old thread and I still desperately need help! If anyone is interested the old thread is here:

    http://bbpress.org/forums/topic/post-import-cleanup-help-needed/#post-134121

    Basically what is happening is that I cannot use the Tools > Forums > Import tool to successfully import my old bbPress 1 forums/topics/replies to my newly upgraded WordPress DB…. in a nutshell here’s what has happened and where I’m at:

    1. Updated WP to 3.5.1 and updated bbPress (initially) to 2.2.4;
    2. Tried to import from my old bb_ tables but first attempt resulted in NO parent forums being converted so all topics showed “No Forum” in the Forum column;
    3. Made a second attempt and made sure to check “Purge all information from a previously attempted import” thinking (silly me) that this would actually purge the previously imported data. FAIL.
    4. Second attempt actually duplicated everything so I had twice as many topics/replies in my wp_posts table;
    5. Following the instructions from the previous thread I manually deleted *all* of the imported topics and replies from my wp_posts and wp_postmeat tables, so that I could start fresh, and then asked for more help to continue since I had no confidence that the import function would work properly;

    Since I received no further replies, I tried importing again after updating the bbPress plugin to the current version (2.3.2) but had the same FAILURE of Parent Forums to import – during the conversion I saw the message “No parent forums to convert”, and all topics showed “No Forum” after importing. Oddly, the parent Forums showed up when you clicked on the link to the Forums from the website, and had a number in the column to show how many Topics were in that parent forum, but clicking on any of the forum names then showed no Topics for that forum.

    SO NOW I’m back to square one – I scrapped all of that again and now have a fresh database of all my wp_ tables WITHOUT the imported bbPress data, and the bb_tables in a separate database waiting to be imported.

    WHAT is the secret to successfully migrating from bbPress 1 to bbPress 2. WHY does the Import Forums not work as it should?

    I have an active (well it used to be anyway) forum that has now been offline for over a month and have numerous complaints from forum members……I REALLY need help to get this fixed….

Viewing 4 replies - 1 through 4 (of 4 total)

  • fontadoni
    Participant

    @fontadoni

    What standalone version do you have installed? I was able to do the conversion a couple of months ago. You need to update your standalone version manually to 1.2 as explained here: http://bbpress.org/forums/topic/upgrade-bbpress-1-0-2-to-2-1-2/page/2/#post-127780
    Then do the conversion.

    Hope this helps.


    TrishaM
    Participant

    @trisham

    Thanks fontadoni – I was at 1.0.2 so I’ll give those instructions a shot. I appreciate your response!


    TrishaM
    Participant

    @trisham

    Aaarrrgh!

    I did everything exactly as specified in the other post, to upgrade from 1.0.2 to 1.2, and now when I try to login to the bbPress admin area to “upgrade” the database I get this message:

    Fatal error: Class ‘Translations’ not found in …/Forum/bb-includes/functions.bb-l10n.php on line 484

    I DO have the /bb-includes/backpress/pomo folder with a translations.php file in it so I don’t know why I’m getting this error, but I cannot login to the forum nor access it (front or back end)….

    I backed up all my files/folder and sql db, then I deleted all the files in my /Forum folder – everything *except* my bb-config.php file and my /my-plugins and /my-templates folder and my .htaccess file…..then I uploaded all of the bbPress 1.2 files including the backpress and pomo stuff just as described…..

    What now???


    TrishaM
    Participant

    @trisham

    Forgot to add that when I try to access the front or back end, all I get is this weird unstyled (no css) page for GlotPress with a search box and a bunch of links…for login, preferences, help guide, trac, etc….NOT my bbpress installation….but the links don’t have a domain associated so they go to non-existent pages on my site.

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.