Skip to:

Hyperlinks ‘a href’ tag not working in posts

Viewing 8 replies - 1 through 8 (of 8 total)
  • Oops… looks like links work find here. In our forums, everything after the “a” gets removed from the source.

    I have the exact same problem. An yes, I already tried deactivating the “Allow Images” plugin. ;-)



    Can you post a link to your forum?

    Are you using a language file other than English?

    Yes, I use a custom german language file (The forum is completely integrated with WP i.e. both configurations are loaded).,

    I just tried posting links while not using the language file: no change, href still gets stripped.

    Deactivating all my plugins doesn’t help either.

    Also, for some reason ” does not get unescaped. I get ” all over the place. This I was able to fix with a custom stripslashes-filter. Its strange though that forum software comes with such bugs out of the box…

    The href must be stripped when saving a post, as it does not appear in the database tables. Some pre_post filter maybe?

    My german forum is located at

    Thanks for your help

    Interesting…I’m still having the same problem, and I also had to apply the custom stripslashes filter. Could that have something to do with it?

    SealedSUn, could you share the custom stripslashes filter you used to fix your unescaped quotes, and the location where you inserted it? (As in, what file? Sorry, PHP newb here)

    Also, are you guys still getting this problem with hyperlinks? Same thing with my installation, and I don’t believe any of my plugins are conflicting with it. Any solution yet?

    Actually, found a sweet solution for the stripslashes:

    Still…any ideas on the ahref?

    It is not help. Need another solution.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.
Skip to toolbar