Skip to:

How to edit the first post ?

  • pmbordeaux



    I realize that an author (creator of a subject) can’t edit his own post. Even the administrator can’t do it.
    Clicking on “Edit” send to another subject !!!

    How can I fix that ?

    Thank’s in advance.

    link from “Edit” for another post : /index.php/forums/Répondre/[numéro du post]/edit/
    it works.

    link from “Edit” for the 1st post : /index.php/forums/Sujet/[titre du sujet]/edit/
    send to another subject !

Viewing 11 replies - 1 through 11 (of 11 total)

  • mithrandir


    In the WordPress dashboard under settings>forums –> under the Forum User Settings, you will see the option:

    Disallow editing after x number of minutes

    You could try increasing the limit, however it does not explain why the keymaster or administrator can not edit a reply or topic.

    It might help in finding the problem by changing the theme to the default wordpress themes and disabling all plugins except bbPress.

    If you could provide more information, regarding the bbPress/wordpress version, themes and plugins, I could try my best to help.



    Thank you mithrandir.

    The time for disallow editing is not the point… I try to create a subject then editing the post and was transfer to the othe subject (see 1st post)

    About my configuration :

    WordPress 4.8.2 avec le thème Smart Magazine

    Admin Menu Editor
    Version 1.8 | Par Janis Elsts | Afficher les détails

    BBP pack Style
    Version 3.6.0 | Par Robin Wilson | Afficher les détails

    bbP private groups
    Version 3.5.9 | Par Robin Wilson | Afficher les détails

    bbP Toolkit
    Version 1.0.10 | Par Pascal Casier | Afficher les détails

    Version 2.5.14 | Par La communauté bbPress | Afficher les détails

    bbPress – Custom KSES Allowed Tags
    Version 0.2 | Par Stephen Edgar – Netweb | Aller sur le site de l’extension

    bbPress Advanced Statistics
    Version 1.5 | Par Jake Hall | Afficher les détails

    bbPress Enable TinyMCE Visual Tab
    Version 1.0.1 | Par Jared Atchison | Afficher les détails

    bbPress New Topics
    Version 1.0.1 | Par c.bavota | Afficher les détails

    Version 2.9.1 | Par La communauté BuddyPress | Afficher les détails

    Dynamic To Top
    Version 3.5.1 | Par Matt Varone, Tim Berneman | Afficher les détails

    GD bbPress Attachments
    Version 2.5 | Par Milan Petrovic | Afficher les détails | FAQ | Upgrade to GD bbPress Toolbox Pro

    GD bbPress Tools
    Version 1.9.1 | Par Milan Petrovic | Afficher les détails | FAQ | Upgrade to GD bbPress Toolbox Pro

    Hide Admin Bar From Non-admins
    Version 1.0 | Par Stranger Studios | Afficher les détails

    If Menu
    Version 0.7.1 | Par Layered | Afficher les détails

    Logged In Content
    Version 1.1 | Par The Tarpon Creek Agency | Aller sur le site de l’extension

    TinyMCE Advanced
    Version 4.6.3 | Par Andrew Ozz | Afficher les détails

    Widget Logic
    Version 5.8.2 | Par wpchefgadget, alanft | Afficher les détails

    Version 2.1.1 | Par David Anderson, Ruhani Rabin, équipe Updraft | Afficher les détails



    I understand, just my two cents, it is most likely an issue with one of the plugins.

    In the wordpress dashboard under settings > bbP private groups –> under the topic permissions tab try to disable topic permissions or change configuration in the plugin.

    I can not replicate your issue as i have tested the smart magazine theme and bbpress is working just fine for me. I am not familiar with the bbP private groups plugin, but i have just tested it, and it is throwing some php errors for me. It might be a compatibility issue with the latest version of wordpress or bbpress.

    I would recommend to start by disabling the bbP private groups plugin first and disable plugins one by one to trace the cause of the issue.

    I’m sorry if i could not be much help, hope you can share your results , and perhaps someone else could offer a solution






    Too bad !!!
    I try everything you say… nothing is working…
    Thank’s anyway for the help.



    Dont mean to waste your time any further, but a quick google search using the keywords “bbpress edit redirect url”, will list a few results with a similar issue. Searching on the bbpress support also returns similar topics. Hope you can get it sorted out soon.



    Before coming here I have looked for these keywords (and others) but didn’t find anything correct. Same thing this morning…

    The problem is that the first post can’t be edited either by the author ou the administrator.

    The link is : /index.php/forums/Sujet/[name-of-the subject]/edit/ but become : /index.php/forums/Sujet/[another-subjet]/

    I tried to take off this [another-subject] but then, it redirect to an unknowned page.

    I really think it’s a bug…



    Sounds like permalink issues. Have you tried to refresh permalinks? Are you using apache or a microsoft IIS web server on your hosting? I have noticed other people with similar problem are on IIS servers.I would look into htaccess if apache or web.config if on IIS or ‘URL Rewrite’ module settings in IIS.

    In wordpress Dashboard>settings>permalinks try setting to default. And click save changes.

    In Dashboard>tools>forums have you tried to repair forums?

    I am not familiar with IIS but the htaccess file should be writable with correct permissions.



    Many thank’s

    The solution was to put the permalinks into “name of the article”

    Now I have to change the shortcode [bbp-topic-index]



    Had to change the buddypress pages to fix the 2nd problem… Everything seems to work fine now.

    Thank’s mithrandir.



    Great! Happy to hear its all sorted out, I will remember to check permalinks in future if I encounter a similar problem myself, ..learn a new thing everyday :), cheers!

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.
Skip to toolbar