Skip to:

How do I change my forum’s path / URL?

  • 775251

    During step 3 of the installation process, I accidentally inputted the wrong URL for my forum.

    It asked me for the Site address (URL), which was defaulted to:

    I changed this to

    Now I can’t access the forums at all, and I can’t figure out how to change the URL back. I looked at bb-config.php, but didn’t see any way to fix this.

    I’m not good with PHP and I’m new to WordPress in general, so any novice advice would be much appreciated!

Viewing 7 replies - 1 through 7 (of 7 total)

  • chrishajer


    Are the files actually installed in the WordPress plugin folder, or in a folder called forums now, located beside or or below the root WordPress folder?


    The files are located in wp-content/plugins/plugins/bbpress

    I’d like to switch my settings to point back to this directory, but can’t find a way to do this.

    Thanks for your help!

    in table bb_topicmeta

    look for meta_key = uri

    Sam Bauers


    You shouldn’t be installing bbPress in the WordPress plugin folder.

    It’s not a plugin.


    @ sambauers: Ok — good to know :)

    So I’ve moved the bbpress files over to

    And now things seem to look better. I can see the admin page for bbpress.

    However, now it seems that a link to the forum stylesheet is broken. When I look at, I see the forum homepage, but with no CSS styling. Then, when I click on to view a forum topic, like, I seem to get redirected to my blog’s homepage. I’m confused!

    Sorry for all the novice questions! Your help is much appreciated.


    One other quick note. I just tried to view the default forum stylesheet in my browser, so navigated to:

    And again was redirected to my blog’s homepage. I’m confused as to why this is happening?



    1. Please post a link to your forum so we can take a look.

    2. No styling usually means the path to the stylesheet is wrong. You can look in the source of the HTML to see that.

    3. Redirecting is probably because you have true or slugs for your permalinks setting, but you haven’t set up permalinks yet. You can set the permalinks to false to get the forum working right now, then take the next step and make permalinks work.

    Either that, or the stylesheet is really not there at the URL you tried, and WordPress is intercepting that and sending you to 404 page.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.
Skip to toolbar