Skip to:

Had 50+ topics, now getting “No input file specified” error

  • Hello All;

    Our forum has been up and running for about 2 months. We have over 50 topics and hundreds of posts.

    This weekend however, something broke. Now when you visit the forum home page that lists the various topics, the list appears, but when you click to view a topic, the ‘No input file specified’ error on a blank page appears. We were not using pretty permalinks, our URL structure is:

    Also, I’ve noticed in the admin panel that when I go to view the list of all topics in the ‘content’ section, the initial list of 30 appears, but when I click the ‘2’ or ‘next’ link to see the rest of the list, the ‘No input file specified’ error shows up again. The same error occurs when I click to view a topic from the admin panel.

    These conversations are there – how do I get them back!!?

    Any ideas what happened??

Viewing 9 replies - 1 through 9 (of 9 total)
  • PS:

    – I have tried putting the script: “Option +Multiview” into .htaccess

    – reinstalling bbPress

    …nothing works.

    Have you got any plugins running?

    I had this error, and removed all my plugins. Error gone.

    I began adding them back one by one until I found a few which were causing problems.

    Sadly, the wordpress integration plugs were what was giving me this specific error, but admin can post anything, and a couple others were causing problems, so they’re gone now and my forum works fine.

    Just a thought.

    Hey dss; thanks, but this didn’t work.



    1. You say the conversations are there. How do you know (phpMyAdmin or something to verify they are still in the database)?

    2. Can you post a URL to the site? Maybe something on your host changed and is working differently now (like they upgraded PHP or something, or changed the Apache configuration to allow overrides in the .htaccess, and that started working all of the sudden or something).

    Hey Chrishajer;

    1. Yes, the conversations are still there – topics are listed and viewable in phpmyadmin – see this update post:

    2. Host is Godaddy – not sure if they changed any php configs… I tried adding “Options +Multiview” to the .htaccess – no luck. Again please see this update post:

    I’ve had problems with godaddy hosting and with other applications in the past. (caching of htaccess files)

    What if you took a copy of bbpress/db and created a local test site and see if things work properly? (xampplite)

    Thanks nuprn1 – I’ll give it a try.



    You said you were not using pretty permalinks, but you most definitely ARE using them.

    This is a link to one of your topics:

    If you were not using permalinks, the link would look like this: (with some additional stuff at the end for replies and post number)

    Try accessing this URL:

    It gets rewritten to and that fails.

    So, do you have mod_rewrite set to true in config.php? If so, turn it off until you can get rewrite rules in place that will work with GoDaddy.

    By turn it off I mean

    $bb->mod_rewrite = false; (no quotes around false)

    Yes, I saw that in the other post chrishajer (pay for help). Thanks so much for your help. I knew it had to be something simple.

    Why would this have worked for so long then break after months of use?

    How can I send you some cake? ;)

    Please contact me through the contact form on the site in my id.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.
Skip to toolbar