Skip to:

Gettting error while creating new topics.

  • While creating new topics from list of topics I am getting this error (red outlined box):”ERROR: Are you sure you wanted to do that?”and no topic is added. I am able to add topics through Dashboard/Topics interface (admin console) WordPress: Version 3.4.1bbPress: Version 2.1.2 I am using custom theme but tried with default “twenty ten” theme. Result is the same – no topic is created and error is shown. Have no idea where it comes from. I suspect this started happening after WP 3.4.1 installation. Any ideas?

    • This topic was modified 11 years, 6 months ago by c-smile.
Viewing 5 replies - 1 through 5 (of 5 total)

  • John James Jacoby


    Shouldn’t be happening with Twenty Ten. Basically, this is a nonce check error. Nonces are used through out bbPress to make sure you’re actually invoking actions on your own request, and that someone hasn’t duped you into doing something you didn’t want to do.

    This is the first I’ve heard of this, so some plugin or theme is really interfering with things. is always running the latest build, so if it’s not broken here, it’s not broken in core.

    Just tried again. Latest WP installation, “Twenty ten” theme with bbPress and Akismet plugins only and still getting this.

    What function may cause this? Will try to find by myself.



    Did you find a solution? I installed BBpress on a site with latest WordPress and Buddypress, but I cannot create new topics from the forums. I have the exact same problem you had…



    the problem remains as on aug 23, 2013!
    it ruins an otherwise good plugIn.
    i have bitnami wp 3.6 stack running on mac
    bbP plugin is version 2.3.2
    almost no other plugin is active.
    pl help… i have been groping for a way out for two days now



    Do you have your wordpress installed on another port other than 80? If so, the problem might be with the nonce verification. I was receiving the wrong requested url and when used returned a false validation. The problem is it uses $_SERVER[‘HTTP_HOST’] which gives something like this ‘’ concatenated with $_SERVER[‘SERVER_PORT’] (‘8080’). The verification should be, instead using $_SERVER[‘SERVER_NAME’] (e.g. ‘’) concatenated with $_SERVER[‘SERVER_PORT’] (‘8080’) to succeed.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.
Skip to toolbar