Skip to:
Content
Pages
Categories
Search
Top
Bottom

Full-Width, can't get full width past main forum page


  • jimbofoxman
    Participant

    @jimbofoxman

    I have a child theme setup using the Child Theme Configurator plugin. I have the following in the child theme folder; style.css, function.php and bbpress.php (renamed from page.php).

    I am using the WP-Englightened theme.

    I copied the page.php to the child root and renamed it to bbpress.php. There doesn’t seem to be anything in that file to remove for the sidebar.

    <?php get_template_part( 'content', 'before' ); ?>
    
    <?php 
    	if (have_posts()) : while (have_posts()) : the_post(); 
    	global $do_not_duplicate;
    	$do_not_duplicate[] = $post->ID;
    ?>
    
    						<div <?php post_class('singlepage clearfix'); ?> id="single-page-<?php the_ID(); ?>">
    
    							<div class="entry">
    
    								<h1 class="page-title"><?php the_title(); ?></h1>
    
    								<?php if ( get_post_meta( $post->ID, 'video_embed', true ) ) {
    									$video_embed = get_post_meta( $post->ID, 'video_embed', true );
    									echo '<div class="post-feature-video single">';
    									echo '<div class="single-video">';
    									echo $video_embed;
    									echo '</div>';
    									echo '</div>';
     								} ?>
    
    								<?php the_content(); ?>
    
    								<div style="clear:both;"></div>
    
    								<?php wp_link_pages(); ?>
    
    							</div>
    
    						</div>
    
    <?php endwhile; endif; ?>
    
    <?php get_template_part( 'content', 'after' ); ?>

    I tried putting this in the style.css file based on a thread here.

    .site,
    .site-header {
    	max-width: 100%;
    }
    
    .bbpress-forums .col-2cl .main {
    	background: none repeat-y right 0;
    	padding-right: 0;
    }
    
    .site-content .entry-header,
    .site-content .entry-content,
    .site-content .entry-summary,
    .site-content .entry-meta, 
    .page-content {
    	max-width: 100%;
    }
    
    .form-allowed-tags {
    	display: none;
    }
    
    div.bbp-breadcrumb, 
    div.bbp-topic-tags {
    	font-size: inherit !important;
    }
    
    #bbpress-forums ul.bbp-lead-topic, 
    #bbpress-forums ul.bbp-topics, 
    #bbpress-forums ul.bbp-forums, 
    #bbpress-forums ul.bbp-replies, 
    #bbpress-forums ul.bbp-search-results {
    	font-size: inherit !important;
    }
    
    #bbpress-forums {
    	font-size: inherit !important;
    }
    
    .bbpress .hentry {
    	margin: 0 auto 48px;
    	max-width: 100%;
    }
    
    @media screen and (min-width: 1008px) {
    	.bbpress .site-content {
    		margin-right: 0;
    		margin-left: 182px;
    	}
    }
    
    @media screen and (min-width: 1080px) {
    	.bbpress .site-content {
    		margin-left: 222px;
    	}
    }
    
    @media screen and (min-width: 1218px) {
    	.bbpress .site-content .entry-content {
    		margin-right: 0;
    	}
    }
    
    @media screen and (min-width: 673px) {
    	.bbpress .site-content {
    		margin-right: 0;
    	}
    }

    If I create a page and use the short code for bbpress and tell it in the page options to do full width it works fine for the main page but not for the rest of them.

Viewing 2 replies - 1 through 2 (of 2 total)

  • jimbofoxman
    Participant

    @jimbofoxman

    Disregard, I atleast have it figured out for now. I copied the theme-styles.php file to the child theme and then searched for;

    	if ( is_page_template('page-landing.php') || is_page_template('page-alt-home.php') ) {
    		$layout = "Full-Width";
    		global $solostream_options;
    		$solostream_options['solostream_layout'] = $layout;

    and added the following right below it…

    	if ( is_bbpress() ) {
              $layout = "Full-Width";
              global $solostream_options;
              $solostream_options['solostream_layout'] = $layout;
         }

    shortgigs
    Participant

    @shortgigs

    I am having issues with this as my theme from themeforest does not have a theme-styles.php – I tried adding your additional code in my child theme functions.php and didn’t work for me, still had sidebar.

    Which .php file would I need?

    Cheers

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.
Skip to toolbar