Skip to:

Forum got installed, but I can’t read any posts!

  • I’m using WordPress 2.6 and I was trying to install bbPress and integrate it and it came up with this error at the end of the installation:

    “Duplicate key name ‘user_nicename’

    >>> User tables will already exist when performing a database integrated installation.”

    My forum got installed, however when I try to click on the topics or the forums or tag, it doesn’t open anything, I can’t get to read any of those. It just stays on the same page.

    The only function I am able to use is the add topic, but I can’t get to read anything I click.

    What should I do? Any advice is greatly appreciated :)

Viewing 7 replies - 1 through 7 (of 7 total)

  • chrishajer


    Can you post a link to your forum?

    Also, WordPress 2.6 won’t integrate well with bbPress The logins won’t work on both the blog and the forum at the same time. But that’s not why you have this problem.

    What directory structure did you use to install the forum? Is it in a sub-folder of the WordPress folder?

    hi chrishajer, thanks for your reply, the link to my forum is

    I didn’t put it in a sub-folder of wordpress, because this is a sub-domain, i put it in its own folder called forum



    So long as it’s in a separate folder from WordPress, you should be fine. You don’t want them in the same folder.

    Try turning off permalinks in the admin. My guess is they’re not supported in your current configuration. If that works, and you can view everything, then you just need to configure permalinks.

    Hi Chrishajer, thanks so much for your help, i had previously written mod rewrite in my bbpress config file and that had caused the unclickable links.

    So i removed that line and turned off permalinks in the admin which helped.

    however whichever method i tried at configuring permalinks at the link as provided, caused internal server error, are there any other way i should go about? Or is it due to the incompatibility between wordpress 2.6 and bbpress



    It has nothing to do with incompatibility between versions; totally unrelated.

    There are two methods there to get permalinks working.

    1. Options +Multiviews (works for some people)

    2. Access with a browser, then grab the displayed text and paste it into your .htaccess file.

    If you tried the first method and you got an internal server error, it sounds like the host does not allow that in an .htaccess file. Try the second method. If that doesn’t work, you might need to contact your host to see what’s allowed.

    ok thanks chrishajer for the specific instructions, I will try it out and let you know of the outcome

    thanks, really appreciate it :)

    thanks chrishajer, it worked!

    just to check, with regards to:

    “Duplicate key name ‘user_nicename’

    >>> User tables will already exist when performing a database integrated installation.”

    what do i need to do to it? or can i just ignore this small error?

    can i thank you with a little something when i get my cheque from google? (not sure when though, hope you don’t mind)

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.
Skip to toolbar