Skip to:

Forum could not be created!

  • chrishajer


    WordPress 2.6.2 svn checkout r8849

    bbPress trunk svn checkout r1794

    I installed WordPress first and that went fine. I logged in and changed my password. Then I went to install bbPress. bbPress installation appeared to go fine. I used simple keys with WordPress so that bbPress wouldn’t choke on them.

    I got to the final step and got a message “There were some errors encountered during installation!” and then I checked off “Show messages” to reveal the following:

    “Forum could not be created!” (that may have been visible before revealing the messages as well – I can’t recall.)

    After that, I tried to access the forum anyway, but I get an error in Firefox3:

    Redirect Loop

    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    The browser has stopped trying to retrieve the requested item. The site is redirecting the request in a way that will never complete.
    * Have you disabled or blocked cookies required by this site?
    * NOTE: If accepting the site's cookies does not resolve the problem, it is likely a server configuration issue and not your computer.


    There is no .htaccess in the WordPress directory or in the bbPress directory. bbPress was installed in a subdirectory of WordPress.



    Any ideas?

Viewing 12 replies - 1 through 12 (of 12 total)

  • Benzilla069


    Hi Chris, I also usually get this problem. I’ve been meaning to document it to the developers but I found a quick fix if you are comfortable in phpmyadmin, unfortunately I’m about to leave for the night so I can’t whip up a PHP script for you.

    The problem is, as it’s mentions that the forum in the database cannot be created and when you try to visit the site it tries to keep finding the first database which is not there and it keeps redirecting forever.

    To fix it, goto the bb_forums table and just insert a record of any data you please(forum_id needs to be 0 iirc or it might be 1) the rest can just be dummy data.

    That will fix it.



    You’re absolutely right. The only bbPress table with data in it is bb_meta, with 15 rows. None of the other bbPress tables have any data in them.

    I did change the bb_ table prefix to bbpress_ and used a different one for WordPress too (wordpress_ instead of wp_) but that was all done pre-installation. The tables are there, just no data in them. It did read the WordPress user table at some point and told me the username to log in with, and “use current password” or something similar. So, somehere along the way, it died. I’m less concerned with getting my install fixed and more concerned with getting the installer fixed.

    Forgive my ignorance but this would seem to be precisely my problem. How do I enter the dunny data you speak of in phpmyadmin and to what areas?

    For those as simple as me this site will hold you hand in doing this.

    I think this problem is because

    when bbpress try to decide wheter this instance has been installed, it use one term, it just check whether the file bb-config.php exists, and the check passed, but when it try to get data from the db, it failed, the script then redirect the user to the install page.

    But when I add dummy data to the bb_forums table and then proceed with the installation, it says “There are existing forums in this database.” Now what do I do?



    The installation should be done first, then you add the dummy data to the table, not the other way around.

    Yeah but the final step of the installation halts with this error.

    Initially, when I tried to set up the forum, it stopped at the final step and displayed an error that said “Forum could not be created”. So after having read this thread, I added some arbitrary data to the bb_forums table and then re-ran the installation. Now in the final step it again throws up an error and says “Forum already exists!”.

    I’m using the same database and the same table prefix as my WP-MU installation, if that is any help. What do I do?



    The original fix was to add the bogus data after the apparently ‘failed’ installation, then your forums would be usable. Is that not the case?

    Also, you used the SAME table prefix for both WPMU and bbPress? I don’t think that’s normally a good thing. I think bbPress would overwrite some WP tables in that case.

    Shouldn’t the prefixes too be the same for integration? But guess what, I just uploaded bbPress 1.0 RC2 and somehow the problem is fixed!! But now when I login to bbPress admin page, I cannot see the link for the Plugins page. Also, if I type /bb-admin/plugins.php, I get redirected to the forum’s homepage! Please help :-)



    No the prefixes should NOT be the same for integration. Use a different table prefix for bbPress tables, and when it comes to integration, the installer asks for your WordPress table prefix so it can use those tables for user data only.

    Start a new topic for your new problem please.

    James Kirk


    I can confirm that I’ve just had the similar scenario play out with the latest version 1.02 and also received the email not sent, failed to install message.

    I popped into the bb_forums table, and added the actual data that I wanted for that first thread, and viola, the site comes up like a clickety clack.

    Thanks for the insight!

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.
Skip to toolbar