Skip to:

fix to: RSS XML Parsing Error

Viewing 7 replies - 1 through 7 (of 7 total)

  • Sam Bauers


    Looks like there is just a little too much white space at the end of the plugin file.

    Open the plugin PHP file and go to the bottom and delete all the blank lines after the final closing PHP tag that looks like this… “?>”

    Yep, that fixed it. Thanks!

    I’m getting the error mentioned above. I’ve searched all the forums and can’t find a fix. I don’t have the above or any plugin loaded. Moreover it gives me the same error on the original theme and my modified theme.

    I also went and made sure that all the files that get included by rss.php don’t have any white space after “?>”. Hitting a brick wall. Anybody have any ideas?

    XML Parsing Error: xml declaration not at start of external entity


    Line Number 1, Column 2: <?xml version=”1.0″?><!– generator=”bbPress” –>


    So how did you fix this problem?

    My bbPress and WordPress run on the same server.

    WP RSS feeds do not have that problem.

    All I get is:

    XML Parsing Error: xml declaration not at start of external entity
    Line Number 2, Column 1:
    <?xml version="1.0"?><!-- generator="bbPress" -->

    I can not parse the forums RSS feed to other pages. :(

    Your rss2.php template possibly has additional space and a new line, <?xml version="1.0"?> should be send at first place (after http header), but it’s not on your forum.

    There is no additional space nor new line in front of the <?xml version="1.0"?> line in rss2.php

    This file is identical to the default (kakumei) theme rss2.php file

    I deleted the “old” and replaced it with the one from kakumei folder.

    And yes, I did upgrade to a newer version. ;)



    It’s fine now. :)

    We had this _blah.php file in my-plugins dir that had just a typed space in it. I deleted it and now the rss feed is fine.

    Thanks for all your help

    I deleted the space from file and it’s fine now.


    I’ve just started an RSS feed. Got it to work perfectly with just 1 item. However, once I tried to add another item to the feed, I got the XML Parsing error. I get: XML Parsing Error: junk after document element


    Line Number 21, Column 1:

    I’ve gone to the RSS Best Practices site and others and it seems I’m doing everything correctly, but it still won’t validate. Any help would be appreciative. Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.
Skip to toolbar