Skip to:

Fix slugs (forums/forum/support-clinic)

  • Young Prodigy


    Hi there,

    I have enabled forums on my site, but it seems like my forum URL is here:

    It’s set to private, so you may not be able to see it, but I’ve taken screenshots below.

    The Forum Root (which is being used as a prefix slug for all forum related content) is “forums.” I’ve checked yes to the show prefix option.

    Then in the single forum settings, I see that the it shows “forum” (singular, not “forums”).
    Here is a screenshot of my settings:

    The forum I created is called “Support Clinic.” It shows up at a URL that says “/forums/forum/ support-clinic/” Here’s a screenshot of my URL:

    How can I get rid of the “forum” in the middle? I just want it to say “/forums/support-clinic/”

    I’ve also set my forum to “Private” (I was logged in as admin when I took the screenshot), so now that gets doubled too: “Private: Private: Support Clinic”

    I only want it to say “Private” once. How can I do that?

    Thank you!

Viewing 3 replies - 1 through 3 (of 3 total)

  • Chad R. Schulz


    I understand why you might want to change the permalinks to “clean” your url. However, this helps distinguish forums from topics from replys. For example or

    You can remove the “forums” part of the permalink in admin settings under forum and Forum Root Slug–Forum Prefix select off. And you can rename the slug for single forum/topic/reply under same menu and Single Forum Slugs. These built-in adjustments are usually harmless and can be changed as needed.

    There are also a few bbPress/WordPress permalink plugins that might help–but they could also make things worse.

    Above all, you want a clean url that both makes sense and remains functional. And I’ve found that messing around too much with permalink settings can often break more than fix.

    And regarding that “Private” issue: Does it display that when you’re not logged in? That’s a curious quirk.


    Young Prodigy


    Hi @chadschulz

    When I’m not logged in, the forum link goes to an error page. I’ve set forum visibility to “Private” because I only want course members for a specific online course I host on my site to have access to the forum. So the “private” issue doesn’t show up when not logged in because nothing shows up.

    Here, take a look:
    It leads to an error page (which I don’t know why it does) when not logged in. Any way to NOT make it lead to error page, but a custom page that just says you must be a course member to see the private forum?

    I’m confused what you mean by renaming the slug for the single forum/topic/reply. I see the settings for single forum, but what I’d really like is this:

    I plan to have different forums for different online classes. Thanks!

    Chad R. Schulz


    When I say single forum/topic/reply slug I actually meant for the single post-type slugs of forum/topic/reply. As the /forums/ slug is just a wrapper for all those bbPress custom post-types. So you could effectively remove the /forums/ wrapper and end up with just If you rename the single /forum/ slug to /forums/ it would become or something similar with topics like

    And adding the topic slug after the forum slug is not intuitive as the topics don’t actually exist inside the forums, they are simply linked to it–similar to a shortcut. This is something that can be done with breadcrumbs, however.

    Again, permalinks can be rather tricky. In fact I’m fairly certain they’re the reason the “Private” forums are leading not-logged in visitors to a 404 page. I’d try putting everything back to the default settings and seeing if that fixes the error. Also, look at any customizing, plugins you might have that could interfere with bbPress defaults.

    BTW, bbPress has a default error message for not-authorized users and “private” forums that should display. Again, something must be off in the settings/configuration.

    My forum has no “private” forums, so I have little experience with this particular issue. Sorry.

    Best of luck,

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
Skip to toolbar