Skip to:

Fatal error: Call to undefined function

  • Hey everyone,

    I recently installed bbPress and thought I was finally done with everything, but now, I get the error

    Fatal error: Call to undefined function bb_get_header() in /usr/home/

    /public_html/forum/forum.php on line 1

    whenever I go to one of the forum categories. I’ve checked over the code in the file and everything seems fine (and this is the only thing that has an error on the forum, as far as I can tell), so I’m not sure why it’s saying the function is undefined…if anyone could help me resolve this problem, I’d greatly appreciate it; I’ve been looking forward to having a functioning forum for quite a while!

    Some additional information, if it helps: I’m using the blank 3 column theme (modified, of course), and the Post Count Plus plugin with bbPress 1.0.2

    Thanks in advance,


Viewing 9 replies - 1 through 9 (of 9 total)

  • Ben L.


    You copied the theme into the root directory and overwrote the core files. You need to upload the theme to /forum/my-themes/THEMENAME, not /forum/.

    I don’t believe so, my theme is where it’s supposed to be, public_html/forum/bb-templates/default

    Check out the instructions around creating a /my-templates/ folder?

    I just did that, and the theme works just as it did before, I’m still getting the error message.

    Try the following:

    * Disable your plugins, and see if the forum link works now

    * If it still doesn’t work, then activate your Kakumei default theme and see if that helps.

    Also – have you tried turning off pretty permalinks?

    None of that did any good. I suppose that would mean somewhere in the root of bbPress, I did something to one of the files. I’ll just replace them and see how it goes…

    Ah ok…

    I notice you also have a blog on your site… did you do anything to integrate the forum and the blog?

    Yes, I did integrate them with a plugin, but that wouldn’t do anything, would it?

    FIXED IT! After I replaced all the php files in the root, it started working again. Thank you very much for the help John!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.
Skip to toolbar