Skip to:

ERROR: You do not have permission to create new topics.

  • newdermeo


    Wordpress – 4.4; bbpress 2.5.8;

    I am wracking my brain! I have looked all over. My website is and all I need is the functionality of bbpress. I have around 40 family members signed up but so far, those who have tried have not been able to start a topic or reply to anything. I am getting the following message “ERROR: You do not have permission to reply.” I do have Ultimate Member installed if that makes any difference. I have installed Buddypress thinking that it might have something to do with it but have determined it is overkill for my site and that it still does not take care of my problem. I keep thinking there is some place I need to go to change user permissions. Please advise. I am willing to give temporary back door access if necessary.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi,
    This is in most cases a plugin that is giving the issue. E.g. you have google analytics or Yoast SEO running ?
    Try deactivating all plugins except bbPress and try then, if it works switch them back on one by one to see which one is causing the issue. (for some people it worked just by stopping and starting plugins)



    Thank you. I found that my user roles and capabilities were all messed up so I installed User Role Editor to fix it. I am now using that plugin along with Ultimate Member (so I can limit page availability in the menu and content). With this combination I have a very good way of having a public face where a limited amount of information is available to the public. Yet very full-featured for our family members. This is a family website with a fun twist and hopefully a multi-generational link to home.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.
Skip to toolbar