Skip to:

Error when install bbpres 1.02: Parse error: syntax error, unexpected T_LNUMBER

  • I have already a 0.9 version of bbpress up and running good.

    I tried to install in a dev folder the newer version 1.02 but I get an error right after I insert the db and username connection info (wp-config creation). The database is empty and the bbpress files are untouched.

    First, I suspected some white spaces in wp-config, but is not that as I let it to be created automatically and checked after that.

    Parse error: syntax error, unexpected T_LNUMBER in /home6/siteurl/public_html/bbpress/bb-includes/backpress/class.wp-http.php on line 281

    The site is at bluhost:

    PHP version 5.2.11

    MySQL version 5.1.42

    Any ideas what might it be? Is 1.02 buggy on some servers?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Is nobody able to help with this issue?



    I guess no one has seen it before. The only information I can find about that error is from Google, and not pertaining to bbPress.

    The only servers it’s buggy on are localhost installations and some WAMP servers, with PHP 5.3. Other than that, it normally works just fine.

    I have just tested it on a separate server and I get the same error.

    I did the same: installed a fresh BBpress. Created database and user for it in backend, went to: http://domain_name/bbpress/bb-admin/install.php and the page shows up correctly. I insert the connection info and connects successfully.

    When I press go to step 2, I get the same error:

    Parse error: syntax error, unexpected T_LNUMBER in /home/domain_name/www/www/bbpress/bb-includes/backpress/class.wp-http.php on line 281

    I will try on my localhost, but for me seems that the bbpress installation folder is corupt!

    The second server configuration, I have tried on is::

    PHP5 (more info) 5.2.12 (default)

    MySQL 5 5.0.82

    On my localhost using WAAMP, it installed successfully however with 5 minor errors (deprecated tags).

    Now wondering if it is any PHP or mysql version bugs on the hosting providers.

    Talked with my hosting provider and told me the wp-includes got corrupted somehow during install. After they put that folder, everything works fine.

    My Dreamweaver CS3 never failed me so far, until now.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.
Skip to toolbar