Skip to:

Error When Attempting to Update bbPress Plugin

  • pcpro178


    Hello. I’m getting this error when attempting to update the bbPress plugin on my site:

    bbPress Update Error

    As suggested here on Stack Overflow, I made sure my file permissions are set properly:

    File Permissions

    I even tried renaming the bbpress directory to bbpress.old without success. Does anyone know how to fix this? I’m not necessarily opposed to reinstalling the plugin, but I want to make sure it’s not going to wipe out any related database records.

Viewing 3 replies - 1 through 3 (of 3 total)

  • pcpro178


    No love for this post? I’m using WordPress version 4.6.1, and I’ve received this feedback from my hosting provider regarding this issue:

    I navigated to templates/default/bbpress/bbpress-templates and the file ‘bbpress-templates’ is a symbolic link to bbpress-templates:

    lrwxrwxrwx 1 sopearly_admin pg1217016 17 Jul 28 18:02 bbpress-templates -> bbpress-templates

    I’m not exactly certain how the symbolic link is referring itself but I’m afraid you may have to inquire with bbpress support as to why the plugin is failing with permission errors due to the file, bbpress-templates.

    We love the post, that’s not the issue. But I have no real answer.
    If it was installed, it should be able to uninstall. Maybe ask an administrator of the server to remove the folder (keep a backup of course).
    But more ideas I don’t have, first time I see this error.



    Hi Pascal. I tried renaming the folder to bbpress.old and then installing the latest version of bbPress, but the admin panel still said that it was on the previous pervion of bbPress. I’d be okay with doing a proper uninstall of bbPress and then doing a clean install, but will that wipe out my bbPress database tables? I need to be able to do this without destroying my community.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
Skip to toolbar