Skip to:

EDIT Button lost after hosting migration! PHP Version?

  • akira010203


    WP Version : 4.73
    BBPress Version : 2.5.12


    I got an issue which start to make me crazy…

    I moved to another shared hosting company and since I did that, my users can’t see the Edit buttn anymore :

    Moderators and administrators have no problems at all, they see correctly all the moderation tools.

    And if a simple user want to edit his post, it’s possible by reaching the link so the rights are correct.

    It is now 1 week I’m working on it, s let me try to list what I’ve already done :

    – Disabled all plugins / themes : NOK
    – Started a fresh version of WP + BBPress : OK
    – Linked my current DB to the fresh install : NOK

    So I started to think about something strange into the DB, which I can’t find.

    I mounted a local version of my site on Wamp too and found another interesting thing, If I run it with PHP 5.6, the EDIT button don’t appear and if I switch t PHP 7, miracle, it shows up!!


    If I switch between all the php versions available (php 5.3 to 7.1) on my new hosting : the edit button is still invisible.….


    If I switch php 5.6 to PHP 7 on my old hosting : the edit button disapear….

    I really need help, I’m lost and my users are getting very annoyed with this issue.

    Thanks in advance for your support!

Viewing 6 replies - 1 through 6 (of 6 total)
  • php.ini, php-config.ini, wp-config.php, .htaccess differences maybe ?



    wp-config and .htaccess no. It’s the default one generated by wordpress.

    About php.ini and php-config, I don’t have these files and I’m on a shared hosting.



    I’ve tried a new thing.

    I created a new WP table by changin the table prefix on wp-config.php, activated all my plugins + child theme, added a new users and created a test forum…

    I got my edit button.

    So it’s in my DB, no ?



    Okay, I merged/splitted a new DB with my current DB, my issue is in wp_options.

    When I backup this table to my fresh DB, the edit button disapear.

    The good news is : This table only contain 6338 lines ….

    Happy to see you move on, hope you find the option that is giving you all the trouble !



    It’s crazy….

    My issue was the “disallow editing after XX minutes” setting…

    I’ve set it to 1000000000000000000 to never disable this function and it seems that the php version and php settings don’t take it good.

    I’ve set it to 10000000000 and now it works well.

    20 hours on this problem! Crazy.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.
Skip to toolbar