Skip to:
Content
Pages
Categories
Search
Top
Bottom

Dutch translation not being activated


  • blux78
    Participant

    @blux78

    Hi all,

    I’m working on a website (being hosted locally for now) which should have a forum translated to Dutch. I’m following all the necessary steps to my knowledge, have downloaded the stable, 100% completed language files, uploaded them to the correct folder as mentioned on this site, but the translation isn’t kicking in.

    Under Settings in our WordPress Admin panel we have set the language to Dutch (Formal), I read that this isn’t desired because the translation for the forum might not kick in? Should I use the other route instead, adding a line in the wp-config file, pointing to accompanying translation files?

    WP version is 4.4.2
    bbPress version is 2.5.8.

    I hope some of you may recognize the problems I’m having and can steer me in the right direction. Thank you in advance for your time and help!

    Kind regards, Blux78

Viewing 8 replies - 1 through 8 (of 8 total)

  • Pascal Casier
    Moderator

    @casiepa

    Goeie morgen,

    Can you point me to the page where you found that procedure ? Translation should come automatically when it reaches 100%, there should be no need to install the translation manually!

    I must however inform you that only the informal dutch is at 100%, not the formal dutch ! So help will be needed to get that one translated.

    Let me know how you want to proceed.

    Alvast bedankt,
    Pascal.


    blux78
    Participant

    @blux78

    Found the solution: simply selecting ‘Dutch’ in the Admin > General Settings section instead of ‘Dutch (Formal)’ in the field ‘Website Language’ did the trick. After saving and refreshing the website, the forum shows the Dutch translation.

    In any way thanks for your time & attention and willingness to help!

    Kind regards, blux78


    Pascal Casier
    Moderator

    @casiepa

    Yes, switching to non-formal Dutch was another option 🙂
    But I thought Formal was a ‘must’ for you.

    Happy to see you’re fixed, enjoy bbPress.

    Pascal.


    Marc
    Participant

    @mbracke

    I have a somewhat similar problem. I have an English site, but want to run a Dutch forum on it. Hence, changing the site’s general settings is no option for me.
    I’ve uploaded Dutch bbpress-nl_NL.mo and bbpress-nl_NL.po files into the folder wp-content/languages/plugins (and there I removed the original en_GB files). I also tried making a wp-content/languages/bbpress folder with the language files, but failed to resolve the problem (which basically is that when Dutch forum participants type in text all of their words get marked with red underlining as if they are not knowing how to write).
    I would very much appreciate some help here.
    The site is called HenHub, and one of the (test) fora is called Facilitators.
    Many thanks in advance!

    Goede middag Marc,

    I’ll have a look around. I see 2 possibilities but not sure they would work. Ping me back here in some days if I would have forgotten about you 🙂

    Pascal.

    Hi Marc,
    I didn’t try any of them, but these are some possibilities:
    1) installing bbPress on the us_US and then downloading the nl_NL bbPress translations and adding them in the bbPress folder (https://codex.bbpress.org/getting-started/bbpress-in-your-language/)
    OR
    2) Go MU and have the main site in us_US and create a subsite in nl_NL
    Pascal.


    Marc
    Participant

    @mbracke

    Hi Pascal,
    Many thanks. I ended up going MU. It worked fine, after installing a Dutch dictionary add-on in my Firefox browser.
    PS I also just installed your bbp Toolkit plugin to auto-check the ‘notify me’ option. That worked just fine too. Many thanks.


    zoekutuit
    Participant

    @zoekutuit

    I had a problem with my Dutch languge setting.
    I just wanted everything in dutch.
    My site was already in Dutch (WordPress 4.2.9)
    This is what i did and one of those things worked.

    – So, my site is in dutch
    – Installed bbPress and it was in English.
    – In my settings i changed the language to English and back to dutch.
    – In home/updates all the way down i ran the language update.

    Now my site and forum are in Dutch.
    Hope this works for others.

    And if not..
    Zoekutuit

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.
Skip to toolbar