Skip to:

Create New Forum Error – Invalid post type

  • Does this plugin work at all?

    So, after a fresh installation, I click , New > Forum and I get an error – “Invalid post type”

    Is this normal behaviour for this plugin? Or is there some secret protocol for getting this thing working?


Viewing 3 replies - 1 through 3 (of 3 total)
  • Sorry for the above comment, it has been a long haul of frustrations in trying to get a forum operating on a client’s website. I tried simple:press and that had issues and I was hoping this would just work after install and I could wrap it up. Anyway, it was just frustrating to encounter yet more undecipherable errors. Not the authors or supporters’ fault.

    If you can help with potential fixes or URLs towards similar problems that would be greatly appreciated.


    John James Jacoby


    Can’t think of a reason this would happen, unless a plugin is actively stopping other post types from being registered correctly.



    Hi, I got the same error as well. In my case it was a permissions issue, because the user role I assigned didn’t have enough capabilities.

    I went to the user’s role and made sure that the user was able to publish, edit and moderate the forums and it was resolved.

    Hope that helps.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
Skip to toolbar