Skip to:

Can’t add additional tags to post

  • When I try adding tags to a post, I get a “You don’t have permission to do that” message and the tags don’t appear.

    I’m using 8.3 with just the integration plugins to WP 2.3 (no includes). I tried adding tags to a post I’d already saved without tags. The first one worked fine, but I couldn’t add additional tags, I’d get a “You don’t have permission to do that” message. I was logged in as a Key Master and had posted the original item as the same user.

Viewing 25 replies - 1 through 25 (of 26 total)
  • I am having this exact same problem with adding tags, except it’s ALSO doing this when I attempt the ‘delete’ option to try and delete a topic. Using the same versions, and logged in as keymaster as well.


    Same problem as well, and it gives the same error if I try to delete individual posts when Javascript is enabled. The regular links seem to work fine.

    Yikes! That’s three of us now. I’m wondering if permissions on a file could be causing this? I’m having a hard time thinking of what else it could be, unless the keyholder permissions got messed with somehow during the update.



    I just did a fresh install of 0.8.3 and I can add tags to existing posts just fine. Maybe it happens only with upgrades? I noticed that on this install, my username is something I chose, rather than the old default of admin, so maybe that is messing up the keymaster somehow.

    Hmm. That could be- I can confirm that I am an upgrader, and my username is Admin.

    Any thoughts on how to remedy it? I’d hate to have to do a completely fresh install.

    Just confirming. I just created a new post, saved it with no tags, then added one tag, which worked, after which, I couldn’t add a second… Haven’t looked into it further, or tried the fresh install, yet…

    Oh, also, I can’t delete the one tag that it allows me to post. I click the X, the red fading delete highlight comes up, but the tag doesn’t go away and still works.

    It seems to be a user thing. I’d been posting from a user that’d been established in WordPress. I updated it to Key Master in bbPress, so it should have all powers. But I found that, apart from tags, I couldn’t delete a post either, same no permission message (same as noted by Jolaedana above). So I logged out and logged in as Superadmin, the default account from bbPress installation, and voila, I can do everything, add tags, delete posts.

    That doesn’t solve the problem. I haven’t tested to see what happens with other users, both already registered from WP and registered through bbPress. But it’s a workaround for me, and a…clue. :)

    I’ve tested it with a user that has moderator permissions, and he can delete posts and add tags just fine.

    So it does, indeed, seem to be a keyholder/admin problem.

    I’m still listed as a keyholder, but I’m wondering if perhaps the steps in this thread might fix the issue?

    No Site Keymasters

    Thoughts before I create a new handle and give it a try? Would it hurt anything?

    Deactivating the “Use Display Name” Plugin fixed this issue for me.



    I experienced the same problem, and deactivating the “Use Display Name” plugin fixes it for me too. Something in the “Use Display Name” plugin may be broken. (But with previous version of bbPress, it works fine.)

    There is another strange thing. The “display names” from WP are still displayed after deactivating the plugin, but only in the topic listings, not in the threads. This isn’t exactly what I’d expected…

    Me, too, deactivating the “Use Display Name” plugin fixes it. But I don’t want to display the username, so for now I’m sticking to logging in as Superadmin when I want to manage tags and whatever else.

    Add me to the list of people with the exact same problem. Disabling the plugin solved my problem.

    I can’t tell you how great this forum is.

    Tracked down the problem in Use Display Name. Basically, it’s a bit overzealous in replacing the user name with the display name throughout the code… including for a function that’s used to check for capabilities. Since the name doesn’t match, the capability check fails.

    Quick partial fix: comment out the following line in display-name.php:

    // add_filter( ‘get_user_name’, ‘bb_use_display_name’, 1, 2 );

    The Display Name will now be used instead of the User Name in some places, but not in others.

    A more complete fix:

    1. In display-name.php, replace:

    add_filter( ‘get_user_name’, ‘bb_use_display_name’, 1, 2 );


    add_filter( ‘get_display_name’, ‘bb_use_display_name’, 1, 2 );

    2. In template-functions.php, add the following function:

    function get_display_name( $id = 0 ) {

    $user = bb_get_user( bb_get_user_id( $id ) );

    return apply_filters( ‘get_display_name’, $user->user_login, $user->ID );


    3. In template-functions.php, find function bb_get_title(), replace the call to get_user_name() with get_display_name()

    4. In template-functions.php, find function get_full_user_link(), replace both calls to get_user_name() with get_display_name()

    5. In profile.php, replace the call to get_user_name() with get_display_name()

    Enjoy :-)

    — scott

    Should this be submitted to Trac?



    I don’t think they handle plugins at trac. At least there is no component for “plugins.”

    I see you already posted in the plugin forum:

    You could try contacting the author of the plugin:

    Michael D Adams

    mda TA blog NOSPACE waffe TOD com (from his blog, and there’s also a wordpress email address for him as well if you look around…)

    Are you thinking this should be handled in the template files, and thus should be submitted to trac, or should someone just update the plugin?



    Great job Scott!



    5. In profile.php, replace the call to get_user_name() with get_display_name()


    Can’t find this — running 8.3 — applied all the other steps, but display names are only showing for some (well, at this point, only for me).

    I thought you were proposing changes to the core files. If so I was wondering if this should be put in as a change to the code database, which would mean submitting a bug to the BBPress Trac database.



    Did you mean me schmitt? Not proposing anything, just trying to figure out why #5 doesn’t work.

    The syntax ‘get_user_name()’ doesn’t exist in my profile.php file under 8.3?



    Matt, the file does exist – it is in the template you are using. If you don’t have one (a template, or a template without this file), bbPress will be using the default one in “bb-templates/kakumei”



    It appears that I may have this issue. I am trying to set up bbPress for the first time and am being told that I do not have permission to set up a new forum.

    My temp site that I am roughing in is I have a theory that is related to this thread. This site was copied from where it had a plugin called “Admin username changer”. One of the first things that I did after the copy was deleted that plugin. When I got this error message and read this thread, my first thought was that maybe deleting it wasn’t enough. Perhaps there was still some embedded something in there someplace. I reinstalled the plugin then used it to change my admin password to admin again then deactivated the plugin.

    It still doesn’t work 🙁




    why couldn’t you create a new admin account (with new username) for yourself then transfer your information to that user, then delete the old account.



    I dont know. CAN I???

    My site is live now. I’m kind of afraid to hit <delete> on the admin account. Are we sure this wont break it?

Viewing 25 replies - 1 through 25 (of 26 total)
  • You must be logged in to reply to this topic.
Skip to toolbar