Skip to:

can’t access admin dashboard

  • I installed bbPress and was able to get into the Admin dashboard right after installation. However once I changed the config file to talk to WordPress I can’t get to the bbPress admin dashboard anymore. It just redirects me to my bbPress homepage.

    Any idea what’s causing the problem?

Viewing 25 replies - 1 through 25 (of 27 total)

  • chrishajer


    What changes did you make to the config file? And what is the URL?

    Is it possible permalinks are redirecting you to the wrong place now, somehow?

    The URL to the forum is:

    The forum itself seems to be working the way it should. When I first created the config file I left the whole “integrating with wordpress” section blank. I didn’t fill it out. Then I filled it in once I found that the pretty slug permalinks weren’t working right. Once I did that the forums worked fine but then I couldn’t get into the main Admin dashboard.

    Here’s my config file as it is now:



    // ** MySQL settings ** //

    define(‘BBDB_NAME’, ‘***************’); // The name of the database

    define(‘BBDB_USER’, ‘******’); // Your MySQL username

    define(‘BBDB_PASSWORD’, ‘*********’); // …and password

    define(‘BBDB_HOST’, ‘************’); // 99% chance you won’t need to change these last few

    define(‘BBDB_CHARSET’, ‘utf8’); // If you are *upgrading*, and your old config.php does

    define(‘BBDB_COLLATE’, ”); // not have these two contstants in them, DO NOT define them

    // If you are installing for the first time, leave them here

    // Change the prefix if you want to have multiple forums in a single database.

    $bb_table_prefix = ‘bb_’; // Only letters, numbers and underscores please!

    // The full URL of your bbPress install

    $bb->uri = ‘;;

    // What are you going to call me?

    $bb->name = ‘ Message Boards’;

    // This must be set before you run the install script.

    $bb->admin_email = ‘’;

    // Set to true if you want pretty permalinks, set to ‘slugs’ if you want to use slug based pretty permalinks.

    $bb->mod_rewrite = ‘slugs’;

    // The number of topics that show on each page.

    $bb->page_topics = 30;

    // A user can edit a post for this many minutes after submitting.

    $bb->edit_lock = 60;

    // Your timezone offset. Example: -7 for Pacific Daylight Time.

    $bb->gmt_offset = -8;

    // Change this to localize bbPress. A corresponding MO file for the

    // chosen language must be installed to bb-includes/languages.

    // For example, install to bb-includes/languages and set BBLANG to ‘de’

    // to enable German language support.

    define(‘BBLANG’, ”);

    // Your Akismet Key. You do not need a key to run bbPress, but if you want to take advantage

    // of Akismet’s powerful spam blocking, you’ll need one. You can get an Akismet key at


    $bb->akismet_key = ‘***************’; // Example: ‘0123456789ab’

    // The rest is only useful if you are integrating bbPress with WordPress.

    // If you’re not, just leave it as it is.

    $bb->wp_table_prefix = ‘wp_’; // WordPress table prefix. Example: ‘wp_’;

    $bb->wp_home = ‘;; // WordPress – Options->General: Blog address (URL) // Example: ‘;

    $bb->wp_siteurl = ‘;; // WordPress – Options->General: WordPress address (URL) // Example: ‘;

    /* Stop editing */

    if ( !defined(‘BBPATH’) )

    define(‘BBPATH’, dirname(__FILE__) . ‘/’ );

    require_once( BBPATH . ‘bb-settings.php’ );


    Nevermind, I took out the WordPress integration stuff and the admin dashboard came back.

    Hi, I’m currently having a similar problem. Having just upgraded to the new version of bbPress and taking advantage of it’s automated WordPress integration. However upon completing this I found I couldn’t access the admin panel.

    I removed the bb-config.php file and ran through the installation again, leaving out the sections relating to WordPress integration. However I still cannot access the administrative panel.

    I’ve tried some of the recommendations around the forum such as this, but to no avail.

    Ideas? Feedback appreciated.



    Something is definitely weird with your site. Check this URL:

    I tried to access (which should just give a 404):

    and it redirected me there.

    I think it’s safe to say it’s something with the host or with some existing rewrite rules in an .htaccess file or something.

    Ahh, no, that’s because I’m running WordPress MU, which seems to have a thing where if the page doesn’t exist then it gives the option to register it as a username.



    I don’t know anything about MU and how integration with bbPress and MU works.

    I installed bbPress on a directory called /discussions on the root of my hosting account, where I have also installed WordPress 2.5, everything on the installation went ok, but after all been done, the admin login to the dashboard gives me the following message:

    You do not have sufficient permissions to access this page.

    Any solution?

    I don’t know anything about MU and how integration with bbPress and MU works.

    That’s the weird thing, after I effectively stopped it being integrated then it still failed to let me into the admin panel. Even more curious is that although my forum user database still exists, it doesn’t seem that bbPress is now recognising it – even though it’s set to use the same database. All users are displaying as Anonymous or Inactive.

    I think I solved why I can’t access the admin panel though… it doesn’t appear that I’m an admin anymore…

    Spent an hour toying around with the database and it seems I fixed it by using a backup then updating the database structure via the message given when first entering the admin panel after upgrade.

    Could just be face value though, I’ll keep things posted.

    I had a similar issue all I had to do was delete the htaccess file that was in my /forums folder from a different installation. Works fine now.

    guys, I’ve never been into the dashboard. I have php5 working and tried to get into the URL,

    but it doesn’t exist? Can you guys help me out?



    You don’t access the admin directly like you can in WordPress. You log in on the front page and then if you’re keymaster, you see the admin link next to your name. If you don’t have an admin link after you log in, maybe you’re not marked as keymaster.

    Need more info on your setup to help. Did you integrate with WordPress? What versions of bbPress and WordPress did you install?

    As you may be able to tell, it asks for a log-in and I have to use my FTP account to log into it for some reason, and I have the latest BBPRESS and WORDPRESS (2.7).



    You have a directory or multiple directories protected with .htaccess. Check the bbpress directory for a file called .htaccess (leading dot, means it’s a hidden file.) It may have been protected through the 1&1 admin panel, or maybe it’s just been uploaded with FTP or by a shell account. That is what’s causing the basic auth dialog you see there. You need to get rid of that, or maybe that’s not the problem you’re talking about at all?

    That is a completely different problem from the one I posted about, although you STILL don’t access bb-admin directly. Log in on the front page of your forum and it will show you an admin link next to your name if you have administrator capabilities.

    Yes I had to download .htaccess from another folder and I edited it, then re-uploaded on to bbpress folder… through Filezilla.



    Are you saying it’s fixed?

    I’m not too sure, I have a .htaccess file within bbpress and another in my main root.

    hey guys,

    I solved this issue for myself by adding a row into my wp_usermeta tablein my wordpress database, and adding this :

    INSERT INTO database.wp_usermeta (

    umeta_id ,

    user_id ,

    meta_key ,



    VALUES (

    NULL , ‘1’, ‘bbpcapabilities’, ‘a:1:{s:9:”keymaster”;b:1;}’


    @atwellpub: Thanks, that fixed the same problem for me!

    I tried atwellpub’s solution — to no avail. Then I replaced “keymaster” with “administrator” in the bb_capabilities row of wp_usermeta table, but that did not work either. (A random guess, anyway.)

    Strange enough, when I re-edited the row and put “keymaster” back in the meta_value, the admin dashboard started letting me in.

    It seems like a file rights issue of some sort, but I did not have an .htaccess file anywhere near the installation path.


    I had to replace all the bb_* in the values of the table bb_usermeta by bb_fr_* since my tables have the prefix bb_fr_

    @atwellpub That worked for me too, it was a big help, thanks



    I am having this same problem. When I integrated by WordPress and bbpress, I lost access to my bb-admin. I believe it’s because I forgot to specify my user roles. I am searching for a fix.

    I’ve tried completely removing by bbPress install and re-doing it, to no avail.

    And I can’t even find a file called “wp_usermeta” in my WordPress database.

    Any suggestions?




    thanks for your advise, it was very useful for me too

Viewing 25 replies - 1 through 25 (of 27 total)
  • You must be logged in to reply to this topic.
Skip to toolbar