Skip to:

Cannot see custom themes ?

  • Hi community,

    Happy new year everybody :)

    Just installed bbPress 1.0.2 to complete a WordPress 2.9 installation. I’m trying to add custom themes, as indicated in all tutorials i could find. This is what i did :

    – created a my-templates directory at the root of the forum (same level than b-templates)

    – uploaded the custom themes into this directory – themes coming from several repository on the Web, none that i did myself.

    Then I cannot see any of my themes on the “appearance” tab in the admin. I tried to upload raw zip files or extracted directory but nothing is detected.

    Any help is greatly appreciated !



Viewing 22 replies - 1 through 22 (of 22 total)

  • chrishajer


    The permissions of the bb-templates folder should be 0755. Same for the folder the theme is in as well. Files in the theme folder should be 0644. Is all that true?

    Great ! It works now.

    It appears that using the Gnome Nautilus integrated FTP function doesn’t respect permissions by default, I re-uploaded every file with FileZilla and everything is OK (even if files are set by default with a 604 permission in filezilla, instead of 644 as you suggested. Looks OK though ?)

    Thanks again chrishajer.



    604 is a weird permission. That’s:

    owner: read/write

    group: nothing

    everyong: read

    My guess is that you’re the owner and only the 6 here matters. You could probably use 0600 and it would work (assuming you ARE the owner.) I can’t even see how the 0 would matter, since everyone can read, but not if you’re in the group. Makes no sense.

    Anyway, so long as the directory is 0755, you’ll be able to get into the directory.



    I’m having the same problem. I changed the theme permissions to 0644, but the theme still doesn’t show in Appearance. 0644, by the way, is different than the kakumei permission. That theme is working.



    644 is good for php files. 755 is needed for folders. You need to change all the folders to 755 permissions, not 644.



    Wish I could say that worked, but it didn’t. All folders are 755, but the custom folder still doesn’t come up in Appearance. I even have the custom folder in bbpress template and my templates and it’s not showing up.



    What is this “custom folder” you’re talking about? Is it a folder inside my-templates? Both folders will need to be 755 permissions, and the theme will need to be valid (with a proper header in style.css).

    Take a screenshot if you can of the folder structure with permissions.

    I’m having the same problem with my custom template; I’m using a recent install of bbPress 1.0.2, and have uploaded my theme to the my-templates directory (I tried it in the bb-templates directory too, as a test) and have checked the directory structure to make sure that’s ok, my style.css header is correct, my permissions seem to be correct (755 on all folders/sub-folders, 644 on all files), there is no mod_security going on with my host… and yet, my theme does not appear in the “appearance” panel of the admin.

    Are there any other details I should check? I need to get this sorted or my client will be unhappy.

    Thanks –




    Nothing else I can think of. Are you sure it’s not a folder inside a folder inside my-templates? It should be:

    my-templates (755 permissions)

    –template-folder (755 permissions)

    —-style.css (644 permissions with a proper header)

    There’s not much more to it.

    Yes, that’s how it’s structured:

    my-templates (755)

    –promoforums (755)

    —-style.css (755)

    —-theme .php files (644)

    This was working fine on my local testing server (MAMP); is there any other way to import a custom theme (I’m wondering if something is being garbled during the FTP upload)…?

    Just thought of something — my style.css file refers via @import to a suite of stylesheets that are contained within a “styles” directory located in my theme folder with (755 permissions). Could that be the problem?

    Well, I just combined all of my various CSS into style.css, and that had no effect.

    I’m totally stumped…



    Post your style.css header here please. Actually, post it at and link it here. It will get garbled here.

    Also, do you have a screenshot.png or screenshot.jpg in the theme folder?

    Can you post a shot of the themes selection in your bb-admin?

    Here’s the link to my css header:

    I do have a screenshot.png (should I get rid of it?)

    I’m not sure what you mean by posting a shot of the themes selection — do you mean a screencap of the “appearance” panel?



    Screenshot is fine, just leave it. I was only wondering if there would be one in the screenshot.

    Yes, post a screenshot of the appearance panel. Sorry for the confusing terminology. I forget what it’s called in different versions.

    Post a screenshot of the appearance panel please. Just wondering what it’s looking like.

    Do you have two instances of bbPress installed, where you might be accessing the wrong one and thus not seeing your theme?



    I just used your header on a copy of the kakumei theme in my my-templates directory, and it was activated and shows up fine.

    My guess is that it’s permissions (or maybe who owns the files.)

    Can you post a file listing of the directory where bbPress is installed, showing permissions and ownership? Screenshot or actual file listing is OK. It’s generally from incorrect permissions.

    Here’s how the appearance/themes-selection screen looks — it’s as if I had no custom template uploaded at all.

    There is only one bbPress installation on the server.

    I don’t know how to get a listing of the directory files w/ permissions. Is it something I can terminal to?

    I’m using Fetch as my FTP client, and I’ve checked (and re-checked, and re-re-checked) the permissions using that tool several times now.

    here’s three shots — one for each directory level, with the “get info” dialog alongside:

    Root Directory (showing bbPress folder permissions):

    bbPress Directory (showing my-templates folder permissions):

    my-templates Directory (showing promoforums folder permissions):

    promoforums Directory (showing style.css file permissions):


    if you have shell access, then browse to bbpress folder

    chmod -R 644 my-templates

    chmod 755 my-templates

    this should fix it



    So, if the theme is where you say it is, why doesn’t this come up?

    Also, this should work:

    Both are not found. It doesn’t look like a permission issue. That would return a different error.

    I don’t have shell access.

    Also, the URLs you posted above were incorrect. The custom theme is promoforums, not promomachines.

    In any case, I ended up scrapping the original installation and starting from scratch, and it all works just fine now.

    Thanks for your help, guys — I appreciate it!

Viewing 22 replies - 1 through 22 (of 22 total)
  • You must be logged in to reply to this topic.
Skip to toolbar