Skip to:

Cannot Integrate users with WP

  • Ok, first of all I should note that this is the second time iv installed this and i still got the “minor error: duplicate user_nicename” message or something like that.

    But this time it worked well and I logged in straight away as the admin. But when I went to login to the WP-Admin, I couldnt log back in the bbPress as admin and as any username.

    So what I then did was clear all the cookies, then it allowed me to log back in as admin in bbPress, so now im in. But… I click on the “Admin” link at the top to go to the settings and all that stuff. and its spits out this:-

    Warning: require_once(../wp-blog-header.php) [function.require-once]: failed to open stream: No such file or directory in /home/picbico/public_html/forum/bb-config.php on line 2

    Fatal error: require_once() [function.require]: Failed opening required ‘../wp-blog-header.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/picbico/public_html/forum/bb-config.php on line 2

    I also might need to mention that I tried to ‘intergrate’ the wordpress functions with it by applying this line to the bb-config.php file : require_once(‘../wp-blog-header.php’);

    thanks for any help let alone all the work you guys have put into this forum. i appreciate it

Viewing 12 replies - 1 through 12 (of 12 total)
  • note:-

    I just removed the “require_once(‘../wp-blog-header.php’);” line from bb-config.php.

    and all seems to be working fine, i can login as admin on both WP-admin and bbpress .

    So what is that line supposed to do, how is that supposed to intergrate the two together i didnt and still dont understand it.



    That line is supposed to allow you to use WordPress functions from inside a bbPress page. It looks like you just got the path to it wrong. Does the file wp-blog-header.php actually exist one directory level up from where the bb-config.php is right now?

    what are the wordpress “functions” i dont get it, coz now iv removed the line and everything works, but i may be missing something whatever these “functions” do. and yeahs i did direct it to the right wp-blog-header.php




    WordPress functions are defined and available to WordPress.

    If you don’t need to use those functions, then don’t include WordPress. You don’t need to include WordPress like that to have integrated users.

    i think i may need those functions to intergrate teh forum “theme” with the rest of the site so it doesnt look like two seperate thigns.

    ill be back after i try this : require_once(‘../wp-blog-header.php’); one more time.

    Do you know if this has to be the first line in the config file or something. and does php use 2 dots ie “../” to mean back a directory, getting confusing.

    And btw i changed it from bb-config-sample.php to bb-config.php before installing it becuase it didnt work.

    the structure is like this : –


    and in bb-config.php i put this line, in the first line after the <?php :-



    after copying that line in bb-config.php would this mean that i cant login as different users in the forum and the blog AT THE SAME TIME.

    for example i just put the line in but this time not at the beginning of bb-config.php and it worked but its not letting me for example login as the admin of the blog and as a different user in the forum AT THE SAME TIME. or is that meant to happen.

    it worked but when i logged in as admin in the blog and then go to login as admin in bbpress (both the same user).. it logins me in as admin but when I click on the “admin” link at the top.

    I get this: –

    Warning: require_once(../wp-blog-header.php) [function.require-once]: failed to open stream: No such file or directory in /home/picbico/public_html/forum/bb-config.php on line 29

    Fatal error: require_once() [function.require]: Failed opening required ‘../wp-blog-header.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/picbico/public_html/forum/bb-config.php on line 29

    and yeahs the wp-blog-header.php is there, otherwise there would have been an error before i even logged in.

    Sam Bauers


    Try using a full path in the require_once() rather than a relative path.

    iv just replaced that line with : –


    and now the entire forum gives me just a white empty page. with no text or anything.

    i just read a post on another thread, and saw this checklist:-

    1. You are running latest versions of WordPress (2.5.1) and bbPress (

    ME – yeahs I am !

    2. You have matched SECRET_KEY in wp-config.php with BB_SECRET_KEY in bb-config.php

    ME – yeahs I have !

    3. You have matched WordPress "secret" database option with bbPress "secret" database setting

    ME – yeahs I have!

    4. You have setup compatible cookie domains and paths in config files (see instructions in bbPress admin)

    ME – I take its these two things i have to add to wp-config.php file: – define(‘COOKIE_DOMAIN’, ”); define(‘COOKIEPATH’, ‘/’);

    if so what do I change those parameters to, or do i leave them blank … im not that familiar with cookies .. :/ (my site is and the forum is )

    5. You are successfully sharing user tables from WordPress with bbPress

    Me – Yeahs I am



    swaymedia: the full path should not be a URL but a filesystem path, something like:


    I tried on my forum and a relative path works there, so I’m not sure that’s the issue.

    Be sure that’s the second line of bb-config.php – the first line should be <?php:



    PHP doesn’t think the file is where you say it is. Can you take a screenshot of the directory listing in an FTP program or command line, and post that? Something does not make sense.

    i tried what you just and no I obviously put the <?php first lol

    here is a screenshot of my situation.

    wordpress still works when i use that “functions” line, but logining to bbpress does not.


    as i said, when i use the line, the domain results in a white empty page

    please help, ill write a tutorial to this if i get it working

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.
Skip to toolbar