Skip to:

Can not upgrade to 2.6

  • I am very new to this, I hope someone can help me.

    I had wp 2.5 installed from fantasico or what ever it is called from Cpanel. any way every thing was fine. I tried to upgrade to 2.6. I followed the instructions. backed up the files then deleted all the files and folder that I was told to delete and kept wp-contents, wp-config.php and htaccess.

    I downloaded 2.6 to my computer, unzipped it. Using fillezilla I transfered the files over. Now this is what is said when you go to my site. (I havnt published my main site being the the internet yet) my site is

    Warning: Unexpected character in input: ”’ (ASCII=39) state=1 in /home/mgjewell/public_html/wordpress/wp-includes/functions.php on line 1706

    Parse error: syntax error, unexpected T_STRING in /home/mgjewell/public_html/wordpress/wp-includes/functions.php on line 1706

    Can someone, anyone please help me urgently.I need very basic instructions. Thank you so much for reading

Viewing 7 replies - 1 through 7 (of 7 total)

  • Ben L.


    1. This is the bbPress forum
    2. Did you edit wp-includes/functions.php (If so, can you paste the contents into and give us the url?)



    ASCII 39 is an apostrophe though. Maybe on line 1706 there is an apostrophe rather than a single quote?

    Hi, so has this forum got nothing to do with wordpress? I tried to post on the word press forum and I couldn’t.

    Please understand I am really new to everything computer.

    I really need help. I didnt know I had to edit wp-includes/funtions.php.

    Can you explain what I have to do. In basic language.

    I really feel stupid when it comes to all this. trying to learn. sorry.If all esle fails do you know of any one that I can pay to fix this for me?

    Thanks. Should I post here from now on or the word press forum if I can. hopefully I wont have to.



    You should post from now on on the support forum for WordPress help, but we can still help you here since we’re mostly familiar with WordPress and bbPress.

    You do *not* need to edit the file, but it looks like you did based on that error, which is why we asked.

    I would try uploading all the files again. Maybe something just got corrupted in that one file, or maybe more files.

    If you need assistance, please contact me at the website listed in my profile.

    Also next time you upgrade I would suggest you use the auto upgrade plugin…makes things a lot easier….or but back all your old files and then use the plugin.

    Thank you I have got my wordpress back, After 2 days of going crazy, I took noproblem’s advice I put back all my files and then used the auto upgrade. Thank you so so much, I’m so happy now.

    Thank you Chrishajer for your help and noproblem.




    Congrats and good luck.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.
Skip to toolbar