Skip to:

Can admin but not browse to forum

  • I managed to get my 1.0 bbPress installed (after having to manually edit the database), and bb-admin works just fine (or appears to), but when I browse to the bb itself, all I ever get is a 404 error. First, I’ve checked the obvious. ‘index.php’ exists in the bb root directory, and everything *seems* to be fine. Is there a log or something somewhere that tells me what it was trying to do so I can debug this?

    Thanks in advance, ye BB-ers!


Viewing 25 replies - 1 through 25 (of 32 total)
  • At first blush, I’d guess that it was an issue with your htaccess file. Did you set one up?

    Welll… when I tried creating the .htaccess file (there are none anywhere else, including my WP installation, which this is integrated with) I got a 500 server error; not a good thing. When I browsed to the suggested permalink URL and tried to change my Permalink settings, it told me it wasn’t an Apache server (The server returned by my ISP, Concentric, has no ‘Apache’ in it — this is a shared (I think Sun) server.)

    So, no joy with your suggestion, which seemed good at first. Thanks.


    Ah shouldn’t have assumed it was htaccess. This is from an earlier post:

    500 Internal Server Errors are usually either related to your .htaccess file or to your file permissions:

    Here’s a number of reports from users who ran into similar issues – it was usually resolved by one of those two solutions:

    Maybe try the permissions angle? Or if not, you could browse the 500-error tag for other possible approaches…

    The 500-error was caused simply because I had an .htaccess file. Once I removed it, things went back to ‘broken normal’. My problem isn’t the 500, but the 404. I’m wondering about the so-called ‘permalinks’, but I believe that applied to pre-1.0 versions. I see no mention of pretty anything in my bb-config.php file.

    Time to get some sleep.


    By the way — just an observation. It would be EXTREMELY HELPFUL if the 404 error page informed us what the bad URL was.



    What is the site URL where we can check this out?

    Hey Chris! I guessed the url from Steve’s profile link… and was able to reproduce the issue he mentioned:

    I did notice one strange thing – when I signed up for an account and clicked on profile, I got a Redirect Loop error in Firefox:

    Good job on guessing the link there, John! You’re exactly correct. I also get an infinite loop when I go to the one forum, i.e.:

    I’m wondering… could this possibly be due to not having any posts recorded for the forum?

    How do I turn on the ‘bb_log’ing facility, and where does bbPress place the log file?

    Next step: At line 784 in, I stuffed the uri into a GLOBALS variable and then displayed it when 404.php ran. It’s trying to redirect to an empty uri, i.e. a uri with a length of zero.

    $location is ‘front-page’

    Okay. So bb_repermalink is being called with a $location of ‘front-page’. $_SERVER is returning the null string and $_SERVER is also empty.

    This causes the code at line 784 to bb_load_template 404.php because the null $uri does not contain the $check string which, in my case is ‘/bbpress/’.

    SO… my question now is… why in the *heck* is the REQUEST_URI null?

    Alright. I commented out the bb_repermalink(); at the beginning of the root index.php, and that appears to have fixed things. Apparently, on my host isp, REQUEST_URI returns null in the root, and this causes the 404 error.

    The only similar case I can see is an issue someone was having with IIS and REQUEST_URI… _ck_ wrote this plugin which resolved the issue:

    It sounds like your situation is pretty different… but maybe worth looking at?

    Well, for the moment, I’ve simply disabled the permalink test in the home page (why would anyone do a permalink test on index.php, anyway? It’s not like anyone is going to link to a forum entry on the home page.

    Hmm, I’m still getting a Redirect Loop in Firefox for the forum links?

    Yea. It get’s it one step further, but still broken. It’s permalinks and the bb_repermalink routine. On my server it ends up re-linking to the same uri, which causes an infinite loop. I tried _ck_’s old code, but it had zero effect. I also used the same principles (constructing the uri from other SYSTEM variables) directly in bb_repermalink, and that does work — the right uri can be constructed, but I haven’t gotten it to work yet. I need to go through the routine and figure out what it does.

    bb_repermalink needs a LOT of work. It is extremely sensitive to $_SERVER variables not being set the way it expects, and it’s tests are not sufficiently detailed. I’m wondering why it would do any kind of redirection on uri’s that are not links to any forum. We’re just trying to browse to the home page, for goodness sake!

    Sounds like bb_repermalink could use some more work – you may be the first person to use bbPress on Solaris:

    If you could report back what you find, maybe we can submit a patch or ticket back to trac… so the main developers can have a look at the issue.

    Good luck!

    I have a php file in my root that calls phpinfo, by the way. If you browse to:

    you can get all the PHP stats from the machine — very informative.

    I’ll have a look at your link. I’d be more than happy to submit a Trac request. In fact, I will do that — as soon as I have dinner ;)

    Awesome! Hopefully Sam and team can address the issue…



    Parse error: syntax error, unexpected '}' in /web/bbpress/bb-includes/ on line 1734

    This is what I’m getting right now. Maybe you’re modifying something?

    Sorry. Yes, I was doing some debug testing in (bb_repermalink), and left it in an abused state. It’s fixed now… with my enhanced 404 error reporting, by the way. Something I also need to post in trac.

    And… I’ll be happy to assist in any way I can. My bbPress installation is completely wedged at the moment and I’ve spent nearly two days now trying to figure out how to get it to work.

Viewing 25 replies - 1 through 25 (of 32 total)
  • You must be logged in to reply to this topic.
Skip to toolbar