Skip to:

Blank page while installing

  • Hi Guys,

    I don’t know what’s going on, i’ve uploaded (twice in case files could be missing) BBpress inside a subfolder called /forum.

    I could see the install screen, i put my db credentials, then created/pasted the content of the config within bb-config.php

    When i move forward the only thing i see is a white screen.

    Are there any specific mysql requirements ?

    Here is an extract of my phpinfo():

    MySQL Support enabled

    Active Persistent Links 0

    Active Links 0

    Client API version 4.1.20

    MYSQL_MODULE_TYPE external

    MYSQL_SOCKET /var/lib/mysql/mysql.sock

    MYSQL_INCLUDE -I/usr/include/mysql

    MYSQL_LIBS -L/usr/lib/mysql -lmysqlclient

    I’ve already installed bbpress in the past without any issues, i don’t know what could i do to fix this ?

Viewing 9 replies - 1 through 9 (of 9 total)

  • chrishajer


    Here are the requirements:

    What does this mean?

    created/pasted the content of the config within bb-config.php

    Also, the relevant info from your phpinfo(); would be the PHP version and the MySQL version. Thanks.

    I have php 5.0.4 and mysql 4.1.20 so apparently this is not the reason why the installation is freezing.

    Just to clarify i put the dbname/user/password when the installation process asked it to me. After that the installation process told me that it couldn’t create the bb-config.php file then i made a copy of the config file, then created manually the bb-config.php and pasted the content of bb-config-sample.php plus the credentials.

    I’m really surprised because all i got is a complete white screen without any error message allowing me to troubleshoot this.

    Thanks for your feedback.

    I just tried again, i got the white screen when i click on “check for configuration file” button.

    I’ve also tried to chmod 777 the config file, i still get the same results.

    I tried to put wrong dbname, user, password within bb-config.php and i got an error message telling me that mysql info are not correct, therefore i assume that when i put the good credentials bbpress was able to connect to the mysql database.

    I’ve also tried to delete the mysql db and recreate everything (new db, new user) and i still have the same error message. This is driving nuts :D



    Do you have access to the error logs to see what the error might be?

    The config file should have 0644 permissions at most, so that’s not the problem.

    I have a root access to the dedicated server (running debian+plesk).

    I’m not sure if you’re talking about this log ?


    Here is a copy of the last lines:

    [Fri Nov 27 10:56:01 2009] [error] [client] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /

    [Fri Nov 27 11:16:44 2009] [error] [client] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /

    [Fri Nov 27 11:36:46 2009] [error] [client] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /

    Thanks a lot for this super fast support !

    Here is the content of the access_log – – [27/Nov/2009:13:14:57 +0100] “GET / HTTP/1.1” 400 299 “-” “-“

    Would that mean that i got an error 400(Bad Request The request contained a syntax error and was not understood.)



    the is a different problem altogether. Looks like someone is scanning the server for vulnerabilities.

    If you have root on the server you should be able to resolve this. It might be in a php_error.log or maybe it is in an apache access or error log, but those lines there are not the ones you want.

    I would determine the IP address you’re visiting from, then grep through the logs for that IP and you should see the error.


    Inside /var/log/httpd/ i’ve been thru access_log and error_log, searched for my ip address but it was not inside any of the logs.

    Is it possible that the script doesn’t triggers any error on the server ?

    I really don’t understand what’s going on.



    Well, if you accessed the forum, it should be logged, with an error or not, right?

    You might need to give someone you trust access to your account to check it out. It’s not normally this difficult.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.
Skip to toolbar