Skip to:

bbP/wP integration incompatible w/ sidebar widgets?

  • Hi everyone, I’ve just had one hell of a night trying to figure out this bbP/wP integration stuff. Eventually, I thought I’d do a clean test install and work from there to see if I could isolate the issue, so I installed:

    BBpress 0.7.3

    WordPress 2.0.5


    Apache 2.0.59

    mySQL 5.0.19

    PHP 4.4.4

    via MAMP on Mac OS 10.4.8

    with WP in root and BBpress as subdirectory “discussions”.

    I then configured wp-config.php and config.php like so:


    define('DB_NAME', 'database');

    define('DB_USER', 'root');

    define('DB_PASSWORD', 'root');

    define('DB_HOST', 'localhost:8889');

    $table_prefix = 'wp_';

    define ('WPLANG', '');

    define('ABSPATH', dirname(__FILE__).'/');





    require_once(dirname(dirname(__FILE__)) . '/wp-config.php');

    define('BBDB_NAME', 'database');

    define('BBDB_USER', 'root');

    define('BBDB_PASSWORD', 'root');

    define('BBDB_HOST', 'localhost:8889');

    $bb_table_prefix = 'bb_';

    $bb->domain = '';

    $bb->path = '/discussions/';

    $bb->name = 'the Forum';

    $bb->admin_email = '';

    $bb->mod_rewrite = false;

    $bb->page_topics = 30;

    $bb->edit_lock = 60;

    $bb->gmt_offset = -8;

    define('BBLANG', '');

    $bb->akismet_key = '***********';

    $bb->wp_table_prefix = 'wp_';

    $bb->wp_home = '';

    $bb->wp_siteurl = '';

    define('BBPATH', dirname(__FILE__) . '/' );

    require_once( BBPATH . 'bb-settings.php' );


    (the 8888/9 ports are MAMP defaults; is the LAN IP of the computer I’m running this on)

    Then I ran the install scripts, and lo and behold, everything seemed to be working great. Then I began to add plugins one by one, and, to make a long story short, found that:

    Whenever the Sidebar Widgets plugin was activated along with a separate widget (including those included with it, and google, as well as akismet, which has a widget built-in), trying to load a BBpress page would yield a blank page. However, if Sidebar Widgets was activated but no widget plugins were, it would work fine–I could even use the integrated widgets (RSS, categories, calendar, etc) on the blog. Likewise, if Sidebar Widgets is deactivated, but all the widgets are activated, it still works fine.

    Also: the Front Page Topics plug-in for bbPress, regardless of any other plugins in wP or bbP, yields a similar blank page on posting a new reply, starting a new topic, making a new forum, or logging out. If I go back and refresh, the topic/reply/forum HAS been created… but the logout attempt is UNsuccessful. Like I said, I tried this with no bb or wp plugins, as well as a variety of them, and its always the same result.

    Ok, its 4:15 in the morning, I have class at 8 and I’m going to go pass out, but hopefully this is enough information for someone to tell me what gives…

    Thanks for reading/any help.


Viewing 14 replies - 1 through 14 (of 14 total)
  • I’m sorry to be a bother, but does *anyone* have any idea what’s going on here? Did I make an error? Do other people have this issue? Is this an established bug? Anything I should try? Do you need any more information? Any response would be appreciated…

    Atsutane (if you read this) – did you every get the issue you mentioned in resolved? That seems to be perhaps a similar predicament… You said you have akismet and ultimate tag warrior installed… do you have the Widgets plugin installed?

    Ok, so I downgraded the test install to 0.7.2, with the same result…

    Ok, so I tested all the combinations of the last two versions of WP and BBP… so its obviously something with my configuration.

    But I found that if I install and activate the incriminated plug-ins in WordPress before trying to run the install script for BBpress, it returns the following error:

    WordPress database error: [Table 'database.bb_forums' doesn't exist]

    SELECT option_value FROM wp_options WHERE option_name = 'widget_text' LIMIT 1

    WordPress database error: [Table 'database.bb_forums' doesn't exist]

    SELECT option_value FROM wp_options WHERE option_name = 'widget_rss' LIMIT 1

    WordPress database error: [Table 'database.bb_forums' doesn't exist]

    SELECT option_value FROM wp_options WHERE option_name = 'sidebars_widgets' LIMIT 1

    WordPress database error: [Table 'database.bb_forums' doesn't exist]

    SELECT option_value FROM wp_options WHERE option_name = 'sidebars_widgets' LIMIT 1

    Now we’re getting somewhere! Anyone? A hint?

    However, if I switch to a theme that supports widgets, and add some to the sidebar, the error message goes away, and I am left with the blank page again. …?


    the problem i have with ultimate tag warrior is because bbpress using the same name function. About akismet, i don’t know what causing it. FYI i dont have any widget plugin install. I only use k2 sidebar module.

    you know, I hadn’t even heard of the k2 sidebar module… I guess I’ll just use that instead, and avoid this whole mess!

    Its a pity this whole thing is so buggy… but its young, I guess. I hope all the kinks get worked out eventually….

    Anyway, thanks for the tip!

    Ok, so I have the exact same issue with the k2 sidebar module. However, I think this means the issue somewhere in the widget plugin API.

    Atsutane – I think this may be a solution for your akismet problem. Try disabling the K2 sidebar module plugin, and enabling Akismet. Does bbpress still work? If yes, comment out lines 374 to 475 of akismet.php, that is, from right before

    function widget_akismet_register() {

    to right after

    add_action('init', 'widget_akismet_register');

    This should allow you to use both plugins at the same time.

    Let me know if that works.

    Yeah i think that will work. I only have that problem when i update wp akismet to the latest version. If i using the old version that dont have widget, i can use it without having any problem.

    Yeah, I just double checked that– 2.0.4 came with a version of Akismet that did not include the widget, hence why the upgrade caused the failure. I’ve just converted all the widgets I needed to K2 modules, which is a fine workaround for now… still, i think its a pretty big conflict, so I put in a ticket on the bugtracker about this. Thanks for your help.

    Yeah also if mdawaffe read this. I hope they gonna change tag function name in future release since they are conflict with ultimate tag warrior :)


    Thanks for the bug report.


    Which function name?


    The function name “is_tag() “

    Fatal error: Cannot redeclare is_tag()

    i’m also facing the same problem, has anyone solved it? or will bbpress work a UTW integration? =P

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.
Skip to toolbar