Skip to:

bbPress Integration plugin for WPMU

Viewing 25 replies - 1 through 25 (of 41 total)

  • exposedplanet


    Hi, new here and looking to add bbpress to WPMU.

    I searched the plugins for ‘WPMU’ and for ‘Integration’ but could not find the plugin mentioned? What is teh name and where can it be found?




    I think it’s this WordPress plugin:



    Ah, that might be it, thanks. I had only checked the bbpress repository :-P

    Is this needed/required for the dreaded WPMU/BP/BBpress integration as well?



    Not sure about BuddyPress at all…

    I have followed video integrating the database with ease. I now have your plug in for WP. I have copied the lines of code and have pasted them into my WPconfig file. What I have noticed with this code, I cant log out off bbpress, and every time I go back to wordpress it logs me out !

    Any step by step directions on the integration would much appreciated !

    I’ve installed a WPMU with buddypress. I’ve also installed a bbpress alpha release. My buddypress users are able to login in bbpress but they require to re-login.

    I’ve also installed bbPress Integration plugin (1.0-alpha-6) and all settings are fine.

    I want to share a common login for both, meaning if user is logged in buddypres then he shouldn’t required to re-login in my bbpress installation. Is there a solution around it?

    Scott any news on a complete fix and or directions on fixing the cookie problem with WPMU and BBPRESS



    I’m seeing a similar issue to dmbware. Install looks ok until I paste the code in from the plug-in and then I can’t log into WPMU. I remove the code from wp-config and I’m OK. Can’t log into bbpress though and it says my password for admin can’t be reset.

    The plugin doesn’t work right out the box in my installation. I’ve configured the settings and added the needed lines to my wp-config.php file, but after doing that I can’t even login in WP (after entering user & pass I just get the same login screen with my username already filled).

    However, if i change the defined ‘SITECOOKIEPATH’ from ‘/wp-admin’ to ‘/’ it works good. I don’t know it this is the right thing. Is it ?

    edit: i have WPMU 2.7.1, BuddyPress 1.0 and bbPress 1.0 RC1.



    I finally got bbPress 1.0 RC1 installed on a new WPMU site…that was an ordeal. I had to install as un-integrated. I then installed the integration plugin but now I cannot log in to either my WPMU or my bbPress. I tried a password recovery but that did nothing. HELP! LOL

    Should I change the “SITECOOKIEPATH” that Detective is referring to? What can I try now that I can’t even log in?



    John James Jacoby


    All of the manual -config.php file changes are “recommended settings” and should not be considered “required settings.”

    It will still take some trial and error to sync the platforms up, and some educated cookie viewing to make sure each platform is dropping the same cookies with the same hosts, paths, domains, and hashes.

    My advice is to make sure that the cookie, key, salt, path, and domain related manual entries into your -config.php files are mirror images of each other, and then start modifying from there if one platform drops a cookie differently than the other.



    What are the current installation instructions for bbPress and WPMU?

    Using the RC2 of bbPress, and the current trunk revision of WPMU, I go through the install and add the secret keys etc, define the primary blog (1), and get to the end but it asks me to create an admin account – it always used to use ‘admin’.

    Am I doing something wrong? When I use the username ‘admin’ it brings an error that the user already exists….

    John James Jacoby


    @hempsworth, I ran into this error myself, but eventually, it seemed to go away after uninstalling bbPress (delete files AND database tables starting with bb_), deleting cookies, and starting over.

    See my post in the other WPMU integration topic and see if any of those settings help you?

    @johnjamesjacoby, I have the same setup and problem as hempsworth. I have repeated the install process now 10 times, same error. I deleted the forum folder (bbpress) deleted the database tables and deleted the cookies. I even tried a different user name instead of ‘admin’, same error. And just for fun I also used a different browser, same error :-(

    John James Jacoby


    ITguy… How comfortable are you with phpMyAdmin? The NEXT thing to try, will be to look in your wp_usermeta table, and see if there are any “bb_” entries in there. Could be some corrupt capabilities in there that are causing headaches?

    I’ll be around for a few more hours so if you’ve got time to go back and forth I’ll keep checking back periodically.

    @johnjamesjacoby, thanks for yoyr quick response and offer to help. I found the following bb_ entries in the wp_usermeta table:

    umeta_id user_id meta_key          meta_value
    14 1 bb_capabilities a:1:{s:6:"member";b:1;}
    16 0 bb_capabilities a:1:{s:6:"member";b:1;}
    24 2 bb_capabilities a:1:{s:6:"member";b:1;}
    55 3 bb_capabilities a:1:{s:6:"member";b:1;}
    75 4 bb_capabilities a:1:{s:6:"member";b:1;}
    102 5 bb_capabilities a:1:{s:6:"member";b:1;}
    112 1 bb_topics_replied 1
    17 1 bb_user_settings m0=o&m1=o
    18 1 bb_user_settings_time 1243961396

    The only odd entry may be the one for user id ‘0’ since there is no entry for that user id in the wp-users table.

    John James Jacoby


    If your bbPress installation is malfunctioning (or incomplete) go ahead and delete all of those out of there, as they will only get in the way.

    Delete those entries, delete cookies, and give the install another try.

    I think this is the same issue I had, with the user_id of “0”. The other odd thing to note, is that all of those say “member” instead of “key master”.

    THANK! That did the trick :-) Will let you know how the rest of the integration goes.

    John James Jacoby


    Phew! haha!

    I’ll be around if you have other problems.

    John, this were I ended up:

    1. Log in as admin to bbPress and went to admin->settings

    2. Enabled ‘bbPress XML-RPC publishing protocol’ in the ‘Writing pane’

    3. In the ‘WordPress Integration’ pane set WordPress Administrator’ to ‘bbPress Key Master’ role. All others to ‘bbPress meber’ and saved the User Role map.

    4. added:

    define(‘COOKIE_DOMAIN’, ”);

    define(‘COOKIEPATH’, ‘/’);

    define(‘COOKIEHASH’, ‘e6bd245d6e82566f2fdcff73419dd3da’ );

    to both wp-config and bb-config files

    5. Copied the 7 unique authentification keys from the wp-config file to the bb-config file adding ‘BB_’ in from of each variable name.

    6. Added to the end of the bb-config file, just be the closing php code:

    $bb->bb_xmlrpc_allow_user_switching = true;

    Saved bb-config.sys

    7. Moved buddypress-enable.php file to the my-plugins folder under the forums folder and activated it.

    8. In the WPMU admin pane selected the BuddyPress->Forums Setup and enter the forum URL, as well as the WPPU admin name and password.

    9. Logout of BuddyPress and bbPress. Logged in to BuddyPress, changed URL to forum, needed to log in, however changing back and forth between the two now needs no further logging in.

    10. Created a new group on the Buddypress site with ‘Enable discussion forum’ selected. Forum is created and visible on the bbPress site.

    11. Enter a topic and comment, bot show up on both sites.

    END of good news. Here is what is not working:

    1. No user integration, only admin works, any other WPMU user is not recognized on the bbPress site.

    2. Existing group’s discussion are not creating forums when toggling the ‘Enable discussion forum’ option.

    3. Only admin can create topics and comments within the group forums (due to problem #1).

    I have done this now 3 times over, reinstalling bbPress (deleting the forum folder, the bb_ tables and bb_ entries in the wp_usermeta) and following the steps above which is a combination of your ‘Forum Integration: Helpful Hints’ posting and the added steps regarding the cookie integration posted on ‘The Easy Button’ and the ‘UMW Wiki’.

    I not sure what to do next to get this right :-(


    I came across your other posting ‘Integrating WPMU trunk and bbPress RC2’ and added the following to bb-press.php:

    // (Sam, I can see you shaking your head right now)
    if ( !defined('ABSPATH') & !defined('XMLRPC_REQUEST') & !defined('BB_IS_ADMIN')) {
    define('WP_USE_THEMES', false);
    include_once( '/absolute/path/to/' );
    header("HTTP/1.1 200 OK");
    header("Status: 200 All rosy") ;

    // WordPress database integration speedup
    $bb->wp_table_prefix = 'wp_';
    $bb->wordpress_mu_primary_blog_id = 1;
    $bb->user_bbdb_name = '';
    $bb->user_bbdb_user = '';
    $bb->user_bbdb_password = '';
    $bb->user_bbdb_host = '';
    $bb->user_bbdb_charset = '';
    $bb->user_bbdb_collate = '';
    $bb->custom_user_table = '';
    $bb->custom_user_meta_table = '';

    // WordPress cookie integration speedup
    $bb->wp_siteurl = ''; // no trailing slash
    $bb->wp_home = ''; // no trailing slash
    $bb->cookiedomain = '';
    $bb->cookiepath = '/';
    $bb->authcookie = 'wordpress_HASH-FROM-FIREFOX';
    $bb->secure_auth_cookie = 'wordpress_sec_HASH-FROM-FIREFOX';
    $bb->logged_in_cookie = 'wordpress_logged_in_HASH-FROM-FIREFOX';
    $bb->admin_cookie_path = '/SUB-DIRECTORY/bb-admin';
    $bb->core_plugins_cookie_path = '/MY-SUB-DIRECTORY/bb-plugins';
    $bb->user_plugins_cookie_path = '/MY-SUB-DIRECTORY/my-plugins';
    $bb->sitecookiepath = '';
    $bb->wp_admin_cookie_path = '/wp-admin';
    $bb->wp_plugins_cookie_path = '/wp-content/plugins';
    define('WP_AUTH_COOKIE_VERSION', 1);

    The result being the user integration is working, HOWEVER admin no longer is recognized as ‘KEY MASTER’ nor does it know about my second bbPress user I created as administrator to be used as the user in WPMU’s Forum integration. Using the admin as that user did not solve the problem either of being able post or create topics/groups. It seems that I either get partial data integration or user integration but not both. What a mess.

    BTW, I have working without any problem WPMU 2.7.1 and BudyPress 1.0.1. Trying to integrate bbPress 1.0-RC2. I had originally working WPMU 2.7.1, BuddyPress 1.0 and bbPress 1.0-Alpha-6. I should have left things alone.


    I took a look at the bb_ entries in the wp_usermeta table and noticed that all entries related to the user capabilities were ‘a:1:{s:6:”member”;b:1;}’. This is rather odd since user id 1 is the admin and that should be listed as KEY MASTER. SO, looking at a old data base backup of my last working version showed the entry as ‘a:2:{s:9:”keymaster”;b:1;s:8:”throttle”;b:1;}’. So I changed it to that value for id ‘1’.

    The result, everything seems to work, user integration, creation of NEW groups and forums, entering topics and replies on BOTH sites. The ONLY thing that is not working is the reactivation of my existing group discussions by toggling the ‘Enable discussion forum’ option in the group admin pane. I will stop here for today. Maybe you have a suggestion tomorrow.

    John James Jacoby


    ITguy, did you remember to do the user-role mapping in your bbPress WordPress integration after you had everything all lined up? I read through your above steps twice and didn’t see it there except for in step 3 before everything was working, but I did also just wake up from a pretty epic nap. :)

    John, Yes, I did so (refreshing the User Role map), especially when I detected that the bb_ entries in the wp_usermeta table related to the user capabilities were ‘a:1:{s:6:”member”;b:1;}’. It did not make a difference. I had to do it manually changing user id’s role to ‘keymaster’.

    Sam Bauers


    Just a note in passing… re-applying the role map doesn’t change the roles of any users that already have a role.

Viewing 25 replies - 1 through 25 (of 41 total)
  • You must be logged in to reply to this topic.
Skip to toolbar