Skip to:
Content
Pages
Categories
Search
Top
Bottom

bbp_get_topic_author_link() returns http:// instead of https:// link

Viewing 9 replies - 1 through 9 (of 9 total)

  • Fuskeduske
    Participant

    @fuskeren

    Hi Milanikolic,

    Have you set your Site Address (URL) in Settings -> General, to HTTPS:// ?

    Aside from that i am not allowed to connect from denmark, giving me timeouts. Do you eventually use geoblocking?

    -Fuske


    Milan.Nikolic
    Participant

    @milannikolic

    Hi Fuske, thanks for your answer.

    Yes, I did changed setings to https.

    And yes, admins are using some kind of geo blocking, I will talk to them and I will let you know if you could take a look.


    Milan.Nikolic
    Participant

    @milannikolic

    Hi Fuske,

    Admins told me that they are blocking only users from Russia. So you sohuld be able to visit the website now.

    Thanks,
    Milan


    eenergy
    Participant

    @eenergy

    I have the same problem: https://dresdner-sc.de/forum/forums/dresdner-sc-forum/
    The general-setting is also correct (https://).


    ragir
    Participant

    @ragir

    I’m having the same problem on a multisite installation. I don’t want to hack the bbpress files since it would be a hassle every update, but it displays a gnarly message in place of the secure connection icon.

    There is no site url setting in a multisite installation, so I can’t set it to https.

    Since switching to HTTPS you need to update your siteurl and homeurl to use HTTPS at /wp-admin/options-general.php

    For multisite @ragir it depends how you have your site setup, this article covers your options on what you can, and can not do to switch to https for multisite 🙂

    How to Set Up HTTPS on WordPress Multisite Without Headaches


    Milan.Nikolic
    Participant

    @milannikolic

    Hi Stephen,

    As I already stated above, I hav already updated siteurl and homeurl to HTTPS, so that’s not an issue.


    eenergy
    Participant

    @eenergy

    Hey Stephen,

    the siteurl and homeurl are correct (https://).
    And yet the avatar images are not retrieved correctly. But only the avatar-links. Everything else is correct.


    shoelaced
    Participant

    @shoelaced

    I’m having this same issue. Is there a reason the function couldn’t be changed to a protocol-relative path, i.e. “//blah.com” instead of “http://blah.com”? That way it’d inherit the correct protocol, no? I’m also getting this error for the avatar images only. If I delete my avatar image I get a green padlock.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.
Skip to toolbar