Skip to:

Attempting Manual Install – Blank when navigating to

  • I must be having a weird issue as I have searched and did not find anyone who posted anything specifically like I am experiencing.

    I have tried integrating and doing the manual install of BBPress in my WP installation in the plugins directory, and quite honestly I do not like it very much – mainly because I would like the forum theme to be different than my main site theme and did not see any easy way to do this.

    I would like the deep integration happening; however, want to install it manually.

    So, I downloaded the .zip file ->Extracted Files->renamed to forum->FTP up to root of the site that has the WP install.

    Then, when I navigate to, nothing happens. I get just a blank screen. This happens across all browsers, no source code when checked and my php errors are set to display and I get none.

    Checked file permissions and they are correct.

    I have deleted and retried the entire process and still no luck. Any ideas on what might be going on here? Thanks!


Viewing 4 replies - 1 through 4 (of 4 total)

  • MommyAndretti2


    I think I’m having the same problem.

    The strange thing is that it *was* working up until this morning. In our case, we moved some folders around – we had an old folder of BBPress and it’s possible when we archived it things went wacky. There’s this in the bbpress.php file:


    * Note to Plugin and Theme authors:


    * Do not directly reference the variables below in your code. Their names

    * and locations in the bbPress class are subject to change at any time.


    * Most of them have reference functions located in bbp-includes. The ones

    * that don’t can be accessed via their respective WordPress API’s.


    which might mean some strange paths were written into the core files. We deleted, and started again. I even went into the wp database to delete all the forums and topics we had made… no luck. A fresh install still turns up a blank page which makes me think there could be another old reference somewhere in the database interfering with things.

    Either that, or it’s some permalink voodoo.

    O mighty BBpress lords (John Jacoby?) I beseech you…. any advice for this dilemma?



    Ah ha!

    I shoulda gone for the obvious.

    In my case it was a plugin conflict.

    I installed 3 SEO-related plugins since I last saw my forum up and running and just now turned them off one by one to see if the problem would resolve.

    Meta Tag Manager ended up being the culprit! I turned it off and everything came in again.

    Even if you don’t have that plugin, try turning off your plugins, if any, one by one to see if that helps…

    Good luck!

    Glad that you got it resolved. My problem was different as it happened just after install. Unfortunately, I got 0 help at all and could not find the answer myself, so I just decided to use Vanilla, which went much more smoothly and works very will with the embed WordPress plugin. Oh well…



    Hey Mike,

    I’m glad you found something that worked for you. I’ll have to look at Vanilla too, I’m not familiar with it. Always interesting to see what’s out there.

    Just for the record, even if you did a fresh install of bbpress, if you had a conflicting plugin this would prevent it working from the get-go…

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Skip to toolbar