Skip to:
Content
Pages
Categories
Search
Top
Bottom

Anonymous Posting: Error posting


  • Matoca
    Participant

    @matoca

    I am run a very successful bbPress forum where I allow anonymous posting. I have never seen this error before so I am a bit confused. About a week ago a person who had already made a new topic returned to post a reply and was given this error message:
    “Error message: your post cannot be posted right now.”

    I believe the original problem may have occurred when I had a what appeared to be a problem with Jetpack. I disabled Jetpack around midnight several weeks ago because a hiccup made all the forum content disappear. I was suspicious of Jetpack because I had just done an upgrade (and I have had other problems with it on other things). So I disabled it. I cleared my cookies, shut down the browser and then went back. The forum content had returned. I enabled Jetpack. The forum content remained fine. I noted two visitors were on the site, probably this person was one of them.

    Then the next day I get an email from this anonymous user that she could no longer post a reply. I thought it was Jetpack so I disabled it again. That did not help because she complained again.

    I then ran all the forum tools, one at a time. I asked her to clear her cookies and cache and then retry again, but with a DIFFERENT browser. Same error message on IE. I then asked her to try on a different computer. I don’t think she did that.

    I went into the forum with myself logged out and was able to make an anonymous reply with her name and email address. So I figured her IP address was the issue, perhaps her business was blocking her from posting? I also checked my Wordfence to see if she had generated any problems in all of her visits to the website with her IP, no issues, all visits were normal.

    I am now getting a report of a different person having the same issues (maybe the other visitor when I disabled Jetpack?) I have never turned Jetpack back on and I have run the forum tools. Wordfence is not showing any errors on the IP address.

    I have really troubleshooted to the point of my knowledge. This user is particularly upset because they interviewed Matt Mullenweg at one point in their career and expressed alarm that WP would allow this to happen. Oh well, I can’t please everyone…

    I would appreciate any help with ideas about how to troubleshoot this better. This user is still unable to post several weeks later and has to email us her messages to post.
    Thank You, Matoca

Viewing 3 replies - 1 through 3 (of 3 total)

  • Pascal Casier
    Moderator

    @casiepa

    Have you disabled or uninstalled JetPack? If only disabled, then please really uninstall it if you don’t plan to use it in the near future.

    But I don’t have any other ideas 🙁


    Matoca
    Participant

    @matoca

    I disabled Jetpack and have left it disabled since this happened.

    However, something happened this Sunday that might be part of this problem, though I can’t be sure. Just posting it here so others can benefit.

    Trying to view my forum on my phone last night, but not logged in. I get the message “oops nothing here.” No forum at all. That’s not right, the forum should be visible to everyone!

    I try to log into my WP site on my phone. Instead of logging me in a form pops up that wants me to prove I am human by performing a simple math equation. This has happened before and I had no idea why, but usually only when I am trying to access the site via my phone. So now I am locked out of the dashboard by this form that is never satisfied by my answers and I can’t see the forum either. Great.

    Searching the WP troubleshooting forum I discover this Prove You Are Human math form is a function of the Jetpack setting called Protect. Many people have been locked out of their dashboard for days at a time. In the forum topic three ways to defeat this are suggested. The simplest, if you can get into your dashboard, is to turn off this Protect setting. More complex is doing it via WordPress.com settings or changing a file in your server.

    Today, Monday, I am able to log into my forum via my computer, and the forum is visible. Jetpack, for some strange reason, is no longer disabled. I have no explanation for that, I left it disabled.

    The first thing I look at are all the Jetpack settings and I unchecked the Protect function. I noticed that the default settings for Jetpack includes many things I had no idea were part of it. Very powerful plugin.

    Will this allow folks who have been blocked to post topic and replies in the forum? I don’t know yet. I would be curious if anyone has tangled with this Protect function prohibiting anonymous users from posting in the forum?


    Stephen Edgar
    Keymaster

    @netweb

    Hmm, strange indeed, I’ve not tried Jetpack with an Anonymous forum.

    If you want to track this down further creating a ticket on our bug tracking site with some detailed information on how your site is setup, what versions and what features you have enabled of WordPress, bbPress, Jetpack etc and how we’d recreate/simulate your setup.

    https://bbpress.trac.wordpress.org/newticket#ticket

    Also if you find just a Jetpack issue you can create a ticket for that here:
    https://github.com/Automattic/jetpack/issues

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
Skip to toolbar